WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#36311 closed defect (bug) (wontfix)

Alpha channel lost when rotating image in Travis CI HHVM.

Reported by: mikeschroder Owned by:
Milestone: Priority: normal
Severity: minor Version: 4.6
Component: Media Keywords: needs-patch
Focuses: Cc:

Description

After fixing Imagick compatibility with HHVM [36916], on Travis CI's version of HHVM 3.6.6, WP_Image_Editor_Imagick::test() is failing:

3) Tests_Image_Editor_Imagick::test_image_peserves_alpha_on_rotate
Failed asserting that 1.0 matches expected 0.0.
/home/travis/build/aaronjorbin/develop.wordpress/tests/phpunit/tests/image/base.php:64
/home/travis/build/aaronjorbin/develop.wordpress/tests/phpunit/tests/image/editor_imagick.php:531

I can't reproduce this locally with HHVM 3.6.6.

See: #35973

Change History (4)

#1 @chriscct7
6 years ago

  • Owner set to mike
  • Status changed from new to assigned
  • Version trunk deleted

#2 @mikeschroder
6 years ago

  • Owner mike deleted
  • Version set to trunk

#3 @netweb
5 years ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from assigned to closed

HHVM 3.6.x LTS is no longer supported, end of support was 1 March 2016

This is also not an issue with HHVM 3.13.x https://travis-ci.org/ntwb/wordpress-travis/jobs/132480889

I've created #36930 to update Travis CI tests from HHVM 3.6.x Ubuntu Precise to 3.13.x Ubuntu Trusty

Closing as wontfix per the above

This ticket was mentioned in Slack in #core-media by mike. View the logs.


4 years ago

Note: See TracTickets for help on using tickets.