WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#36321 closed defect (bug) (duplicate)

Cannot use visual editor after dragging a WP_Editor container

Reported by: flixos90 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: TinyMCE Keywords:
Focuses: javascript Cc:

Description

When a WP Editor is placed inside a draggable element and that element is dragged (using JavaScript), the visual editor of that editor is not usable any longer: Its content disappears and it's no longer possible to even click into the editor frame.

The first time I saw this happening was inside a custom element that I made draggable using the jQuery UI Draggable plugin. After that I also tested the editor inside a regular WordPress meta box, and when I dragged that metabox, the same issue occurred, so it the bug was not related to my own JS implementation.

While investigating, I discovered that this seems to be a general problem of TinyMCE - I couldn't find a proper solution yet though.

Change History (1)

#1 @ocean90
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19173.

Note: See TracTickets for help on using tickets.