WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#36348 closed defect (bug)

"View Details" link in plugins list table shows details of wrong plugin

Reported by: thomaswm Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3.1
Component: Plugins Keywords:
Focuses: Cc:
PR Number:

Description

I'm using the "Social" plugin which has recently been removed from the official WordPress plugin directory. It had been available under https://wordpress.org/plugins/social/ and it is installed in the wp-content/plugins/social/ folder on my server.

Since this plugin has been removed from the wordpress.org plugin directory, the "View Details" link in the plugins list table points to

https://<host>/wp-admin/network/plugin-install.php?tab=plugin-information&plugin=social-media-builder&TB_iframe=true&width=772&height=907

Therefore, the plugin details overlay shows information for a completely different plugin, which is also called "Social", but has a different slug.

Change History (3)

#1 follow-up: @Clorith
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23318.

#2 in reply to: ↑ 1 @thomaswm
4 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Replying to Clorith:

Duplicate of #23318.

There's a difference between these two. In #23318, the reporter has renamed the plugin folder so that it matched the slug of another plugin from the wordpress.org plugin directory. This is not the case here.

In my case, the plugin is installed in a folder called social. There is currently no plugin with that slug in the wordpress.org plugin directory.

The "View Details" link points to a different plugin with the slug social-media-builder.

#3 @Clorith
4 years ago

  • Status changed from reopened to closed

You are correct that the problem is not worded exactly the same, but the underlying issue is, the base report for #23318 is that the details for the plugin shown is for a different plugin (which is the same problem as you are having).

You'll notice that other topics that have the same problem as yours have also been tagged as duplicates of that thread because it all boils down to the same core problem: There's no explicitly unique identifier for the plugins, and as such the API finds the closest possible match if no identical match is available.

See for example #13928 which is also marked a duplicate of #23318

Note: See TracTickets for help on using tickets.