WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#36360 closed defect (bug) (duplicate)

Multisite - WP defaults to LT language even if it set to EN

Reported by: KestutisIT Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4.2
Component: Networks and Sites Keywords:
Focuses: ui, administration, multisite Cc:

Description

So I had default multisite setup. Main language of main site was LT. Later I switched that site to EN.
Now when I add new WP multisite's site, and in install I select that site language - English, after I click - "go to dashboard" -> general settings. I see the system language is still LT (Lithuanian). And all text of course is in LT. But when I switch language to English in General settings, then for that website it saves the correct language.

Change History (4)

#1 follow-up: @dd32
5 years ago

  • Keywords reporter-feedback added

Hi @KestutisIT

Can you please verify that the Default Language setting in the Settings panel of the Network Admin is set to what you expect?
It sounds like you may have changed the language of the Main blog, but that hasn't changed the defaults for new sites.

#2 in reply to: ↑ 1 @KestutisIT
5 years ago

Replying to dd32:

Hi @KestutisIT

Can you please verify that the Default Language setting in the Settings panel of the Network Admin is set to what you expect?
It sounds like you may have changed the language of the Main blog, but that hasn't changed the defaults for new sites.

In Network Admin, the default language is set to LT. Now I changed it to EN. But the issue was in the creating new site, when I did selected 'EN' (specified site language). Because when you create a new website in Multisite, WP does allow to choose that site language in dropdown.

Last edited 5 years ago by KestutisIT (previous) (diff)

#3 @KestutisIT
5 years ago

  • Keywords reporter-feedback removed

#4 @ocean90
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #36918.

Note: See TracTickets for help on using tickets.