WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

#3638 closed defect (bug) (fixed)

img attributes ALL CAPS when using new 2.1 VRE w/ Opera

Reported by: HandySolo Owned by: Andy
Milestone: 2.5 Priority: low
Severity: normal Version: 2.1
Component: TinyMCE Keywords: opera image uploader
Focuses: Cc:

Description

Just noticed this with a fresh install of 2.1. First time trying admin stuff with Opera 9.10/XP.

Added an image using the updated image uploader and all the attributes are displayed in the "Code" view as ALL CAPS. For example:

<a TITLE="e" HREF="http://example.com/wp-content/uploads/2007/01/e7401.jpg">
<img ALT="e" SRC="http://example.com/wp-content/uploads/2007/01/e7401.thumbnail.jpg" />
</a>

Even the hyperlink attributes get capitalized. For what it is worth, doing a normal hyperlink is ok, just when it comes via the image uploader.

If I open the same post with Firefox, and then go to "Code" tab, the attributes are fine (lower-case).

TinyMCE issue? Opera issue?

Change History (15)

comment:1 @Znuff8 years ago

  • Owner changed from anonymous to Znuff
  • Status changed from new to assigned

It's confirmed from several other users on irc://irc.freenode.net/wordpress

comment:2 @markjaquith8 years ago

  • Owner changed from Znuff to Andy
  • Status changed from assigned to new

Andy, your ticket. Sounds like a TinyMCE issue.

comment:3 @Nazgul8 years ago

  • Milestone changed from 2.1.1 to 2.1.2

comment:4 @rob1n8 years ago

  • Component changed from Administration to TinyMCE

I've verified this with SVN trunk. Identical actions on Firefox result in attributes with proper cases, while Opera has them all uppercase. I would believe this is an Opera issue, but either way TinyMCE should probably work around it.

comment:5 @hakre8 years ago

Attributes are made UPPERCASE while switching between the Code and Visual Pane as well. So this must be javascript related. I've checked TinyMCE Documentation Wiki but could not find any option that is defining this behaviour. Maybe someone else is better in seraching there.

According to their FAQ, TinyMCE should produce XHTML conform code. (http://wiki.moxiecode.com/index.php/TinyMCE:FAQ#Why_does_TinyMCE_strip_away_attributes_or_tags_from_my_source.3F) Taking this for granted means, that not TinyMCE is making the attributes uppcercase but WP is since uppercase attributes like HREF or TITLE aren't XHTML valid.

comment:6 @hakre8 years ago

Some more Infos:

Opera 9 Support with TinyMCE is named as (WinXP / MacOSX):

Opera 9 OK(1) OK(1)

Where (1) is for Partially working. (They do not have Linux Support in their chart, how lame). So let's assume these are k4ckn00bs and Opera 9 is just simply not supported well by TinyMCE. This does not answer the question completely wether this is a TinyMCE or WP Problem but I tend for TinyMCE and TinyMCE should fix this. Maybe someone should call their professional support and ask for fixing this forever?

Source: http://wiki.moxiecode.com/index.php/TinyMCE:Compatibility

comment:7 @foolswisdom8 years ago

  • Milestone changed from 2.1.3 to 2.2

comment:8 @foolswisdom8 years ago

  • Milestone changed from 2.2 to 2.3

comment:9 @HandySolo8 years ago

Some testing with 2.2 and Opera 9.20 has me cautiously optimistic. At first blush, the upper-casing issue is now gone.

comment:10 @HandySolo8 years ago

sorry,scratch that. All was cool until I actually uploaded an image (lost my mind for a moment there). The issue persists in that scenario.

Apologies.

comment:11 @Gesu8 years ago

Same issue here (Opera 9.21, Win XP, WP 2.2), and I would add that with Opera there're also some problems with word wrapping. Sometimes the editor just starts a new line, or it continues on the same one even if text goes over the limit, instead of starting a new line.
I thought it could be reported here, instead of opening a new ticket (I still can create it, if someone thinks it's the case).

comment:12 @foolswisdom8 years ago

  • Milestone changed from 2.3 to 2.4

comment:13 @hakre7 years ago

Can confirm that the bug is still in with 2.3.3 and using opera. Shouldn't there be a tinymce option to tell tinymce to use lowercase attribute names?

comment:14 @lloydbudd7 years ago

hakre, thanks for confirming this. This issue is unlikely to be resolved in a maintenance release. Do you have the resources to test if the issue is still present on trunk?

comment:15 @azaozz7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Opera wasn't fully supported by TinyMCE 2.x, but works well in 3.0

Note: See TracTickets for help on using tickets.