WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#36388 closed defect (bug) (invalid)

is_comments_popup() Notice on WordPress 4.5-RC1

Reported by: anghelalexandra Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Comments Keywords:
Focuses: Cc:

Description

Hi there,

I'm testing my plugin on the 4.5 Release Candidate and saw the following notice:

Notice: is_comments_popup is <strong>deprecated</strong> since version 4.5 with no alternative available. in /mywppath/wp-includes/functions.php on line 3664

Call Stack:

0.0001 629632 1. {main}() /mywppath/index.php:0
0.0001 634688 2. require('/mywppath/wp-blog-header.php') /mywppath/index.php:17
0.1542 38318032 3. wp() /mywppath/wp-blog-header.php:16
0.1542 38318208 4. WP->main() /mywppath/wp-includes/functions.php:952
0.1593 38440488 5. do_action_ref_array() /mywppath/wp-includes/class-wp.php:737
0.1593 38441488 6. call_user_func_array() /mywppath/wp-includes/plugin.php:601
0.1593 38441568 7. PLL_Frontend_Links->check_canonical_url() /mywppath/wp-includes/plugin.php:601
0.1593 38441696 8. is_comments_popup() /mywppath/wp-content/plugins/polylang/frontend/frontend-links.php:471
0.1593 38441864 9. _deprecated_function() /mywppath/wp-includes/deprecated.php:3710
0.1594 38442424 10. trigger_error() /mywppath/wp-includes/functions.php:3664

FYI - I'm not using is_comments_popup() anywhere in the plugin.

Change History (2)

#1 in reply to: ↑ description @anghelalexandra
4 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Sorry, just saw the problem is from another plugin, deactivating that plugin takes care of the issue.

Just ignore this.

Replying to anghelalexandra:

Hi there,

I'm testing my plugin on the 4.5 Release Candidate and saw the following notice:

Notice: is_comments_popup is <strong>deprecated</strong> since version 4.5 with no alternative available. in /mywppath/wp-includes/functions.php on line 3664

Call Stack:

0.0001 629632 1. {main}() /mywppath/index.php:0
0.0001 634688 2. require('/mywppath/wp-blog-header.php') /mywppath/index.php:17
0.1542 38318032 3. wp() /mywppath/wp-blog-header.php:16
0.1542 38318208 4. WP->main() /mywppath/wp-includes/functions.php:952
0.1593 38440488 5. do_action_ref_array() /mywppath/wp-includes/class-wp.php:737
0.1593 38441488 6. call_user_func_array() /mywppath/wp-includes/plugin.php:601
0.1593 38441568 7. PLL_Frontend_Links->check_canonical_url() /mywppath/wp-includes/plugin.php:601
0.1593 38441696 8. is_comments_popup() /mywppath/wp-content/plugins/polylang/frontend/frontend-links.php:471
0.1593 38441864 9. _deprecated_function() /mywppath/wp-includes/deprecated.php:3710
0.1594 38442424 10. trigger_error() /mywppath/wp-includes/functions.php:3664

FYI - I'm not using is_comments_popup() anywhere in the plugin.

#2 @SergeyBiryukov
4 years ago

  • Component changed from General to Comments
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.