Make WordPress Core

Opened 15 years ago

Closed 15 years ago

#3646 closed defect (bug) (fixed)

RTE - Mini letter type in editing window

Reported by: joao2's profile joao2 Owned by: ryan's profile ryan
Milestone: 2.1.1 Priority: highest omg bbq
Severity: normal Version: 2.1
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

I've just upgraded to WP 2.1. Since the upgrade, the window that one uses to type a post now uses a very small letter type. How can one solve this?

I've even tried a clean install in another directory, but the result is the same. Text is so small in the MCE editor that one can hardly see it!

I've tried a clean install on another server, and it works well.
Can a server not support the Javascript in WP 2.1?
I think I'm going to revert to WP 2.0.7.

Attachments (1)

https-on.diff (641 bytes) - added by andy 15 years ago.

Download all attachments as: .zip

Change History (20)

#1 follow-up: @joao2
15 years ago

  • Milestone changed from 2.2 to 2.1.1

#2 in reply to: ↑ 1 @Znuff
15 years ago

  • Priority changed from normal to lowest
  • Severity changed from normal to trivial

Replying to joao2:
JavaScript is not server-based. It's a matter of styling probably. It's not a defect.

#3 @foolswisdom
15 years ago

  • Milestone changed from 2.1.1 to 2.2

Can you provide a screensheet?

#4 follow-up: @foolswisdom
15 years ago

OS? browser? version?

#5 in reply to: ↑ 4 @norbertb
15 years ago

Replying to foolswisdom:

OS? browser? version?

Although I'm not the original bug reporter, I can replicate the bug in the following enviroments:

  • Windows XP Pro SP2 NL, Internet Explorer 7 EN , wp v2.1


  • Windows XP Pro SP2 NL, Mozilla Firefox 2.0.0.1 NL, wp 2.1

#6 @foolswisdom
15 years ago

  • Keywords TinyMCE RTE added; MCE removed
  • Priority changed from lowest to normal
  • Severity changed from trivial to normal
  • Summary changed from WP 2.1 MCE Editor - Mini letter type in editing window to RTE - Mini letter type in editing window

norbertb, thank you! Can you include a screenshot? Circling what is wrong? If you have a screenshot of what looked correct before that would be excellent too!

#7 @MichaelH
15 years ago

Saw this just today on a Windows plan at ixwebhosting for a fresh new 2.1 installation.

Here's what it looks like on ixwebhosting account:
Small text

Here's what is look like on asmallorange host:
"Normal" text

I'm using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.9) Gecko/20061206 Firefox/1.5.0.9

PHP info from ixwebhosting:

  • PHP Version 4.4.1
  • System Windows NT IIS100 5.0 build 2195
  • Build Date Mar 14 2006 22:18:06
  • Server API CGI/FastCGI

#8 @andy
15 years ago

There is a stylesheet applied to the editor contents. Please verify that you have this file:

wp-includes/js/tinymce/plugins/wordpress/wordpress.css

#9 @MichaelH
15 years ago

Andy, just confirmed that file is there and intact.

#10 @andy
15 years ago

We need to be sure your browser is loading that stylesheet. Right-click in the editor, click This frame => Reload. That might get the stylesheet to load.

If not, we'll need to look at it with firebug or liveheaders or something that can sniff out the client/server interactions.

#11 @MichaelH
15 years ago

Doing the frame => reload seems to do nothing but lock the screen--I can't enter any text on the Write Post screen. I then have to reload the whole page or click on another Admin menu bar option.

#12 @andy
15 years ago

View the source of that frame and see what stylesheets are linked, if any.

#14 @andy
15 years ago

Excellent! That clue will lead to a fix. Open up tiny_mce_config.php and replace this:

if ( $_SERVER['HTTPS'] ) {

with this:

if ( $_SERVER['HTTPS'] == 'on' ) {

#15 @MichaelH
15 years ago

Great job! Thanks Andy, that fix worked.

@andy
15 years ago

#16 @andy
15 years ago

  • Keywords has-patch added; TinyMCE RTE removed
  • Milestone changed from 2.2 to 2.1.1
  • Owner changed from anonymous to ryan
  • Priority changed from normal to highest omg bbq

Patch attached for the fix tested above.

#17 @markjaquith
15 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4812]) Link to TinyMCE css file with http scheme on all server setups. Props MichaelH and Andy. fixes #3646

#18 @markjaquith
15 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Re-opening for 2.1.1 ... previous commit was for trunk

#19 @markjaquith
15 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [4872]) Link to TinyMCE css file with http scheme on all server setups. Props MichaelH and Andy. fixes #3646

Note: See TracTickets for help on using tickets.