WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 14 months ago

#36469 closed defect (bug) (worksforme)

Chrome bug when placing cursor before or after Gallery shortcode (WPView)

Reported by: bduclos Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4.2
Component: TinyMCE Keywords:
Focuses: Cc:

Description

To reproduce this issue: in the Visual editor mode, type a long text followed by a Gallery shortcode (you have to scroll to see the gallery).

In Chrome, if you click to the left or right of the Gallery WPView to place the cursor, the editor jumps to the top.

Change History (9)

This ticket was mentioned in Slack in #core-editor by azaozz. View the logs.


4 years ago

#2 @azaozz
4 years ago

  • Milestone changed from Awaiting Review to 4.6

I've recently seen Chrome jump to the top in several cases. Don't think it is specific to wpView. Worth investigating further.

#3 @iseulde
4 years ago

  • Keywords needs-patch added

Confirmed. Still an issue after [37446].

Last edited 4 years ago by iseulde (previous) (diff)

This ticket was mentioned in Slack in #core-editor by iseulde. View the logs.


4 years ago

#6 @iseulde
4 years ago

Seems to be only a problem when the full height editor is enabled. Otherwise it works fine.

#7 @scottbasgaard
4 years ago

Having issues replicating based on:

To reproduce this issue: in the Visual editor mode, type a long text followed by a Gallery shortcode (you have to scroll to see the gallery).

In Chrome, if you click to the left or right of the Gallery WPView to place the cursor, the editor jumps to the top.'

#8 @azaozz
4 years ago

  • Milestone changed from 4.6 to Future Release

Still can reproduce inconsistently and only in Chrome. May happen only once on the first click inside the editor after page load. Looks like something that was caused by a change in the browser, but can't find a good way to prevent it.

Punting for now as it is an annoyance that rarely happens. Sometimes these bugs are symptoms of other focusing problems in the browsers and get fixed with them. Think it's best to look again in couple of months.

#9 @azaozz
14 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Don't seem to be able to reproduce this any more. Seems fixed in Chromium.

Note: See TracTickets for help on using tickets.