WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 17 months ago

#36480 closed defect (bug) (wontfix)

TinyMCE: use the API for inline toolbars

Reported by: azaozz Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: TinyMCE Keywords: needs-patch
Focuses: javascript Cc:

Description

Switch our inline toolbars to use the new TinyMCE API. It was improved several times and now has a callback we can use to precisely position the toolbar and take into account our UI changes like "editor scrolling" and DWF.

Change History (6)

This ticket was mentioned in Slack in #core-editor by azaozz. View the logs.


5 years ago

#2 @iseulde
5 years ago

  • Focuses javascript added
  • Keywords needs-patch added
  • Milestone changed from Future Release to 4.6

This ticket was mentioned in Slack in #core-editor by iseulde. View the logs.


5 years ago

This ticket was mentioned in Slack in #core-editor by iseulde. View the logs.


4 years ago

#5 @iseulde
4 years ago

  • Milestone changed from 4.6 to Future Release

#6 @azaozz
17 months ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from new to closed

We weren't able to switch to using that API in WP. It has several differences to the way inline toolbars are implemented in WP, and patching them has proven impractical.

Note: See TracTickets for help on using tickets.