WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#36511 closed defect (bug) (invalid)

Database update won't work

Reported by: jackyv Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5
Component: Database Keywords: close
Focuses: Cc:

Description

No error message.
I updated my blog to version 4.5
The blog works fine.
However, if I try to go to the adminpanel, wp tells me that the database has to be updated.
I click the button and I get redirected to a page with nothing on it.
http://example.com/wp-admin/upgrade.php?_wp_http_referer=%2Fwp-admin%2F
Next time I go in the admin panel WP is again asking me to update the database.
Same story ...
I don't know what to do.
(btw. I seem to be logged in, because I can see the admin bar hovering at the top of the page)

Attachments (1)

empty.jpg (20.4 KB) - added by jackyv 3 years ago.

Download all attachments as: .zip

Change History (7)

#1 @Clorith
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hiya, and welcome to Trac!

This sounds like it might be a cache problem, we observed the same problem for some users for WordPress 4.4.

Trac is intended for handling WordPress core bugs and enhancements though, so we do request that support enquieries be posted to our forums at https://wordpress.org/support, but ot get you started there's a section on caching in our Master List for WordPress 4.5 at https://wordpress.org/support/topic/read-this-first-wordpress-45-master-list

You'll want to look specifically at the Varnish bit, it may require you to ask your host if they can clear any cache if they don't provide any interface for you to do so your self.

#2 @Ipstenu
3 years ago

  • Keywords close added

Hi jackyv. I want to correct Clorith. It's not Varnish, it's probably memcached.

Sadly this is not a WP core bug but one in your setup. Most likely you have some kind of database caching (like memcached or APC) installed on the server and it needs to be flushed. If you don't know how, ask your webhost if they can please flush the server-side cache for you. Tell them it's the database case and I would recommend saying 'It may be memcached' just to spur them in the right direction :)

If you have wp-cli installed, you can run this on the command like: wp cache flush

In most cases, that clears it up.

#3 @SergeyBiryukov
3 years ago

I click the button and I get redirected to a page with nothing on it.

If the page is literally empty, there might be a PHP error, you might find more details in the PHP error log.

If the page does show an upgrade button, it's most likely a caching issue, as per the comments above.

@jackyv
3 years ago

#4 @jackyv
3 years ago

Thanks for the quick responses!

I've a second blog on the same server.
Update worked like a charme.

I attached a screenshot of the "empty page"

Last edited 3 years ago by jackyv (previous) (diff)

#5 @jackyv
3 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

#6 @Ipstenu
3 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

I'm really sorry, but this is not a bug.

For support, please post to our forums at https://wordpress.org/support

Note: See TracTickets for help on using tickets.