WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#36516 closed defect (bug) (worksforme)

4.5 Throws a SNAP error on Google Chrome Canary

Reported by: robertp2014 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5
Component: General Keywords:
Focuses: Cc:

Description

Updated 3 sites so far and all three now throw a SNAP error page can not be displayed on Google Chrome Canary, no problem on Google Chrome. Additional problem all three had problems with the update, maintaince screen never revered to updates, core had to be updated, only worked after reloading, reinstall gets me Forbidden

You don't have permission to access /wp-admin/update-core.php on this server.
see http://www.crisisinfohub.com
http://www.airsoftandpaintball.com
http://www.beautyschool.tips

Change History (3)

#1 @robertp2014
5 years ago

This bug is concurrent with a bug in Google Chrome Canary that causes fuzzy unreadable text in right click boxes and apparently crashes wordpress 4.5 sites throwing a Snap error. The following I found in Step 1 on the Google Forum fixed my Wordpress 4.5 problem.

FroFro91 said:

Here's what i did in steps:

1) windows search and type ClearType , you'll get "Adjust ClearType Text" , click on it, then UnCheck "Turn on ClearType" don't cancel or close it yet, click on next and continue to "tune all your monitors" once you're done with all that, restart canary chrome and check if context menu problem is gone, if not, go to step 2

2) type chrome://flags/ in ur canary address bar, it will take you to a page with features, look for DirectWrite and enable it (if it was already enabled, then disable it, restart canary and re-enable it again). Now the context menu and bookmarks font issue should be gone, but the programs names in your computer or websites might have fuzzyness with their fonts, so go to step 3.

3) if the text in websites still continue to look blurry/jaggy then go back to windows search and type ClearType and enable it again.

#2 @swissspidy
5 years ago

  • Keywords close added

I just worked on a few sites running 4.5 using Chrome Canary and haven't found a single problem. Regarding the blurred text, the solution you posted is the one to go, as it's more of a problem in Canary instead of WordPress. It's not a stable version of Chrome after all.

Regarding the permission error, I'd suggest you to post in the support forums as it's mostly related to file permissions, .htaccess rules and similar configuration, depending on your hosting provider.

#3 @ocean90
5 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.