WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#36517 closed defect (bug) (invalid)

Notice of deprecated since 4.5 pops up in core

Reported by: RDall Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5
Component: General Keywords: close
Focuses: Cc:

Description

After updating to 4.5 this morning, I got this notice with the debug on.

Notice: get_currentuserinfo is deprecated since version 4.5! Use wp_get_current_user() instead. in /home/site/public_html/wp-includes/functions.php on line 3662

Since notice is in wp-includes and not a theme then the deprecated is core(s) responsibility in my understanding.

Attachments (1)

Screen Shot 2016-04-13 at 1.44.27 PM.png (1.2 MB) - added by RDall 5 years ago.
Screenshot of Notice

Download all attachments as: .zip

Change History (4)

@RDall
5 years ago

Screenshot of Notice

#1 @swissspidy
5 years ago

  • Keywords close added

get_currentuserinfo() was deprecated as part of #19615.

If a theme is using this function, it needs to be updated to use wp_get_current_user() instead. The notice mentions wp-includes because this is the place get_currentuserinfo() is located in. However, it's the theme developer's responsibility to actually update his code.

#2 @jorbin
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

The notice showing that line and function is do to that being the location of _deprecated_fuction. Core does not use currently use get_currentuserinfo anywhere. If you can replecate on a default theme with no plugins active, please reopen with steps to reproduce.

#3 @SergeyBiryukov
5 years ago

#36565 was marked as a duplicate.

Note: See TracTickets for help on using tickets.