WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#36518 closed defect (bug) (invalid)

Emojis support broken in 4.5

Reported by: ozzyr Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5
Component: Emoji Keywords:
Focuses: Cc:

Description

Emoji support works in 4.4.2, but something went wrong in 4.5.

Change History (7)

#1 @mnelson4
4 years ago

Hey @ozzyr thanks for mentioning the affected version, but you should probably give some more details on what exactly went wrong. Eg are emojis not appearing in 4.5 which appeared fine in 4.4.2? Where are you seeing this? Can you add new emojis ok? And do you have any plugins active that might affect this?

#2 @ozzyr
4 years ago

it seems the JS is firing in Chrome, but not Safari, or Firefox.

no plugins active that would effect it.

i added a bunch of emojis here: http://demos.wpsitecare.com/alpha/emojis/

try different browsers and you'll see :)

#3 follow-up: @Ipstenu
4 years ago

Works fine in Safari and Firefox for me.

#4 in reply to: ↑ 3 ; follow-up: @ozzyr
4 years ago

Replying to Ipstenu:

Works fine in Safari and Firefox for me.

Firefox:
https://www.dropbox.com/s/lmqy960dtm9pkss/Screenshot%202016-04-13%2015.43.57.png
https://www.dropbox.com/s/59crwxhnllymxju/Screenshot%202016-04-13%2015.44.19.png

Chrome
https://www.dropbox.com/s/sixra6xyml974u1/Screenshot%202016-04-13%2015.44.48.png
https://www.dropbox.com/s/bin8v03x5oqzuau/Screenshot%202016-04-13%2015.45.13.png

The screenshots in chrome are what I used to see in all browsers before upgrading

#5 in reply to: ↑ 4 ; follow-up: @peterwilsoncc
4 years ago

  • Keywords close added

Replying to ozzyr:

The operating system's emoji are used for preference in browsers with full support. In browsers that do not offer full support, such as Chrome, the emoji script runs and they are replaced with images.

The different styles of emoji your screen shots is because Firefox offers full support, Chrome does not.

#6 in reply to: ↑ 5 @ozzyr
4 years ago

Replying to peterwilsoncc:

Replying to ozzyr:

The operating system's emoji are used for preference in browsers with full support. In browsers that do not offer full support, such as Chrome, the emoji script runs and they are replaced with images.

The different styles of emoji your screen shots is because Firefox offers full support, Chrome does not.

related to this? https://github.com/WordPress/WordPress/commit/2c277e3952fdd73b9ca5f2594e6bd159ef40bd86

#7 @pento
4 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Firefox had a regression in FF41 related to rendering emoji in a canvas element, caused by an upgrade to their rendering engine. WordPress was affected by this, as it uses canvas to detect if the browser was able to render emoji or not.

FF46 (currently in beta) fixes this bug. I just tested WordPress in FF43, 45 and 47 - 43 and 45 use WordPress' emoji replacement script, 47 correctly chooses to use the system emoji.

Note: See TracTickets for help on using tickets.