WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#36547 closed defect (bug) (duplicate)

Tests_DB_Charset::test_strip_invalid_text core unit test is failing constantly with my setup.

Reported by: onnimonni Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: Database Keywords:
Focuses: Cc:

Description

Hey I'm running latest wordpress from git://develop.git.wordpress.org/ in docker container on OS-X.

I have xdebug enabled and these files are mounted from OS-X into docker container.

The docker container source code is available: https://github.com/devgeniem/docker-alpine-wordpress

System information:

Distro: Alpine Linux
System: Linux 9d7ddeebf0b9 4.3.3-dhyve #1 SMP Sat Feb 6 00:10:17 UTC 2016 x86_64
PHP: 7.0.5

Output from testing:

root@:/data/code# /root/.composer/vendor/bin/phpunit tests/phpunit/tests/db/charset.php
Installing...
Running as single site... To run multisite, use -c tests/phpunit/multisite.xml
Not running ajax tests. To execute these, use --group ajax.
Not running ms-files tests. To execute these, use --group ms-files.
Not running external-http tests. To execute these, use --group external-http.
PHPUnit 5.3.2 by Sebastian Bergmann and contributors.

.........................................F....................... 65 / 98 ( 66%)
.................................                                 98 / 98 (100%)

Time: 2.12 seconds, Memory: 24.00Mb

There was 1 failure:

1) Tests_DB_Charset::test_strip_invalid_text with data set #41 (array(array('big5', 'a�@ba�@ba�@ba�@ba�@ba�@ba�@ba...@ba�@b', array('byte', 10))), array(array('big5', 'a�@ba�@ba', array('byte', 10))), 'big5_byte_length')
big5_byte_length
Failed asserting that Array &0 (
    0 => Array &1 (
        'charset' => 'big5'
        'value' => 'a�@ba�@ba?'
        'length' => Array &2 (
            'type' => 'byte'
            'length' => 10
        )
    )
) is identical to Array &0 (
    0 => Array &1 (
        'charset' => 'big5'
        'value' => 'a�@ba�@ba'
        'length' => Array &2 (
            'type' => 'byte'
            'length' => 10
        )
    )
).

/data/code/tests/phpunit/tests/db/charset.php:374

FAILURES!
Tests: 98, Assertions: 172, Failures: 1.

Change History (2)

#1 @netweb
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @onnimonni thanks for the ticket, it's an issue with MariaDB 10.1 databases, we're also already tracking this issue in #33171 so I'll mark this as a duplicate of that ticket.

#2 @SergeyBiryukov
3 years ago

  • Component changed from General to Database
Note: See TracTickets for help on using tickets.