WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#36568 closed defect (bug) (fixed)

The Content of a Link is too Long in Comments Page

Reported by: zjhzxhz Owned by: rachelbaker
Milestone: 4.6 Priority: normal
Severity: normal Version: 4.5
Component: Comments Keywords: has-patch has-screenshots commit
Focuses: ui, administration Cc:

Description

If there's a link in a comment, the link will be displayed in comments page in backend.

For example I have a coment:

Suppose a [link](http://VeryVeryLongUrl.VeryVeryLongUrl) have very long url and other content.

And the content of comment will be displayed as the screenshot below.

A way to fix it is add overflow: hidden; for #the-comment-list td.comment class in CSS.

Attachments (2)

Screenshot from 2016-04-18 12:30:39.png (180.8 KB) - added by zjhzxhz 4 years ago.
36568.patch (347 bytes) - added by rachelbaker 4 years ago.
Add word-break: break-all to urls on Moderate Comment screen

Download all attachments as: .zip

Change History (10)

#1 @ocean90
4 years ago

  • Component changed from General to Comments
  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release

Hello @zjhzxhz, thanks for your report. It seems like you have Akismet installed?

WordPress displays the link only on the moderate screen, see #36380. But I can confirm that the issue exists there too. Looks like we should add something like word-break: break-all;.

#2 @SergeyBiryukov
4 years ago

  • Focuses administration added

@rachelbaker
4 years ago

Add word-break: break-all to urls on Moderate Comment screen

#3 @rachelbaker
4 years ago

It doesn't look like the word-break: break-all is actually needed at all. In Chrome 51.0.2704.63 beta (64-bit), I see no difference with or without the patch.
Screenshot without patch: https://cloudup.com/cPwL4iSJScZ
@ocean90 Are you seeing something different?

#4 @rachelbaker
4 years ago

  • Keywords has-patch 2nd-opinion added; needs-patch removed

#5 @ocean90
4 years ago

  • Keywords 2nd-opinion removed

@rachelbaker Right, line breaks in text can occur for certain characters, like spaces or hyphens. The example in the screenshots doesn't contain such characters.

#6 @rachelbaker
4 years ago

  • Keywords has-screenshots added

Aha!

Without patch:
https://cldup.com/QLtGpXtQju-3000x3000.png

With patch:
https://cldup.com/YymewBXL0g-2000x2000.png

#7 @rachelbaker
4 years ago

  • Keywords commit added
  • Milestone changed from Future Release to 4.6

#8 @rachelbaker
4 years ago

  • Owner set to rachelbaker
  • Resolution set to fixed
  • Status changed from new to closed

In 37607:

Comments: Break the inline display of comment content urls on the Moderate Comment screen

Uses the CSS rule word-break: break-all.

Fixes #36568.

Note: See TracTickets for help on using tickets.