WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#36620 closed defect (bug) (fixed)

Feeds using an rss-http content type are now served as application/octet-stream

Reported by: johnbillion Owned by:
Milestone: 4.5.1 Priority: normal
Severity: normal Version: 4.5
Component: Feeds Keywords: has-patch fixed-major
Focuses: Cc:

Description

In r36230, rss-http was removed as an allowed content type for feeds as it's not used in core. This means that any custom feeds that are using that content type are now being served as application/octet-stream instead of text/xml, which means the client attempts to download the feed.

This problem has been seen on some live sites hosted on WP.com VIP, breaking some custom feeds.

Attachments (1)

36620.patch (693 bytes) - added by johnbillion 3 years ago.

Download all attachments as: .zip

Change History (11)

@johnbillion
3 years ago

#1 @johnbillion
3 years ago

  • Keywords has-patch added; needs-patch removed

#2 @swissspidy
3 years ago

Duplicate of #36334? The bug was reported there but I couldn't really reproduce it.

#3 @johnbillion
3 years ago

  • Milestone 4.5.1 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #36334.

#4 @johnbillion
3 years ago

  • Milestone set to 4.5.1
  • Resolution duplicate deleted
  • Status changed from closed to reopened

Actually, #36334 is close but not quite the same. That issue is about the inability to override the feed's mime type via a filter to get past the issue of application/octet-stream being the default content type for custom feed types.

Last edited 3 years ago by johnbillion (previous) (diff)

#5 @swissspidy
3 years ago

@johnbillion I see. Thanks for the clarification. In that case, 36620.patch seems fine to me.

#6 @johnbillion
3 years ago

In 37282:

Feeds: Revert [36230] which removed the rss-http feed content type. Removing this means that any feeds which are using this feed content type are now being served as application/octet-stream instead of text/xml.

See #36620

#7 @stevenkword
3 years ago

Looks like this should be closed now?

#8 @swissspidy
3 years ago

  • Keywords fixed-major added

@stevenkword After it has been backported to 4.5.1

#9 @johnbillion
3 years ago

In 37284:

Feeds: Revert [36230] which removed the rss-http feed content type. Removing this means that any feeds which are using this feed content type are now being served as application/octet-stream instead of text/xml.

See #36620

Merges [37282] to the 4.5 branch.

#10 @johnbillion
3 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.