WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#36622 closed defect (bug) (fixed)

Post excerpt is causing unit test failures when searching for 0

Reported by: boonebgorges Owned by: boonebgorges
Milestone: 4.6 Priority: normal
Severity: normal Version:
Component: Query Keywords:
Focuses: Cc:

Description

This is basically a duplicate of the problem solved in [36520] for 'post_content', except this time for 'post_excerpt'. See #35762, #31025.

Change History (1)

#1 @boonebgorges
4 years ago

  • Owner set to boonebgorges
  • Resolution set to fixed
  • Status changed from new to closed

In 37280:

Tests: More explicit fixture content when testing s=0 query string.

After [36647], the unit test generator sequence can put a 0 into the
'post_excerpt' field of a post fixture, causing false positives.

See [36520] for a parallel fix involving 'post_content'.

Fixes #36622.

Note: See TracTickets for help on using tickets.