WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#36626 closed defect (bug) (duplicate)

Inserting a PDF in text editor produces double quotes in anchor href

Reported by: johnjamesjacoby Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5
Component: Media Keywords: needs-patch
Focuses: Cc:

Description

When inserting a PDF file into the content via the text/HTML editor, the mark-up it produces is malformed:

<a href="http://src.wordpress-develop.dev/wp-content/uploads/2016/04/thing.pdf"">thing</a>

Note the two trailing "'s at the end of the href attribute.

I believe this is a regression from 4.4, which seems to work okay, but included a rel="" attribute, too.

Attachments (1)

36636.mov (696.6 KB) - added by johnjamesjacoby 4 years ago.
Movie of bug in action

Download all attachments as: .zip

Change History (3)

@johnjamesjacoby
4 years ago

Movie of bug in action

#1 follow-up: @ocean90
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #36578.

#2 in reply to: ↑ 1 @johnjamesjacoby
4 years ago

Replying to ocean90:

Duplicate of #36578.

Sorry about that. Thanks for the cleanup.

Note: See TracTickets for help on using tickets.