WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#36643 closed defect (bug) (duplicate)

Imagick can throw uncaught exceptions in image functions

Reported by: wonderboymusic Owned by: wonderboymusic
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:
PR Number:

Description

getimagesize() calls, and some others, need to be replaced with new wp_*() versions that have a try { ... } catch ( Exception $e ) { .... } block

Change History (2)

#1 @wonderboymusic
4 years ago

  • Owner set to wonderboymusic
  • Status changed from new to assigned

#2 @ocean90
4 years ago

  • Milestone 4.6 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #36587.

This was fixed upstream and we're going to blacklist this version.

Note: See TracTickets for help on using tickets.