WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 10 months ago

#36650 closed defect (bug) (worksforme)

inline link editor won't disappear in Chrome and obscures text

Reported by: mashupmom Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5
Component: Editor Keywords:
Focuses: Cc:

Description

When I create a link using the new inline link editor in WP 4.5, the inline link editor doesn't disappear and obscures text when I'm editing in Chrome, and the only way to make it disappear is to save the post or to create a new link elsewhere in the post and cancel out.

Attachments (7)

inlinetoolbar.png (10.4 KB) - added by mashupmom 4 years ago.
toolbarwontleave.png (25.2 KB) - added by mashupmom 4 years ago.
stuck editor.PNG (11.0 KB) - added by reddalek 4 years ago.
IMG_0940.PNG (109.0 KB) - added by reddalek 4 years ago.
Bug on Chrome on iOS
add-link-1.png (15.8 KB) - added by azaozz 4 years ago.
add-link-2.png (7.7 KB) - added by azaozz 4 years ago.
stucklinks.png (30.9 KB) - added by reddalek 4 years ago.

Download all attachments as: .zip

Change History (22)

#1 @SergeyBiryukov
4 years ago

  • Component changed from General to Editor

#2 follow-up: @AUMW-Jay
4 years ago

I thought viewers of this thread should know that the cause of this issue is plugins that haven't been updated for 4.5, specifically the Rel Nofollow Checkbox plugin https://wordpress.org/plugins/rel-nofollow-checkbox/, and probably others.

#3 in reply to: ↑ 2 @mashupmom
4 years ago

Replying to AUMW-Jay:

I thought viewers of this thread should know that the cause of this issue is plugins that haven't been updated for 4.5, specifically the Rel Nofollow Checkbox plugin https://wordpress.org/plugins/rel-nofollow-checkbox/, and probably others.

Sorry, I meant to come back and update. Yes that is correct. rel-nofollow and also ultimate nofollow turn out to be causing the same issue.

#4 @Clorith
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

I'm going to go ahead and mark this as invalid as it was reported to have been caused by a plugin conflict.

#5 follow-ups: @reddalek
4 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

I am able to reproduce this bug on Wordpress 4.6 and Chrome on a clean install without any plugins activated.

Steps to reproduce:

  1. Highlight text in the text editor
  2. Click to insert a link
  3. Enter a URL and then click on the editing gear icon
  4. Click 'Update'

The inline link editor remains stuck on the screen.

@reddalek
4 years ago

#6 in reply to: ↑ 5 @azaozz
4 years ago

Replying to reddalek:

I am able to reproduce this bug on Wordpress 4.6 and Chrome on a clean install without any plugins activated.

This works properly here in latest Chrome, Firefox, IE and Edge.

Could you empty your browser's cache and try again. If still able to reproduce, could you look for JS errors in the browser console and paste them here.

#7 @reddalek
4 years ago

Thanks for taking a look.

I can still reproduce (in Chrome, latest version, Windows PC) after clearing my cache, going incognito or using another computer. It's a little fiddly, but I can even reproduce on Chrome on iOS (screenshot attached). No errors or warnings in the console.

I can't reproduce on Edge either.

@reddalek
4 years ago

Bug on Chrome on iOS

#8 @SergeyBiryukov
4 years ago

  • Milestone set to Awaiting Review

#9 in reply to: ↑ 5 ; follow-up: @azaozz
4 years ago

Replying to reddalek:

Steps to reproduce:

  1. Highlight text in the text editor
  2. Click to insert a link
  3. Enter a URL and then click on the editing gear icon
  4. Click 'Update'

Still can't reproduce it in any browser. After clicking on "Update" it closes the modal and shows the "link preview" toolbar in the editor. Tested on Win10.

In step 3 after you click on the gear, what do you see in the "Link Text" field in the modal? It should be the text you selected.

@azaozz
4 years ago

@azaozz
4 years ago

#10 in reply to: ↑ 9 ; follow-up: @reddalek
4 years ago

Replying to azaozz:

In step 3 after you click on the gear, what do you see in the "Link Text" field in the modal? It should be the text you selected.

Yes, I see the text which is selected.

For what it's worth, I just tested on somebody's open Wordpress demo site (http://demo.talkpress.de/trunk/) and could recreate exactly the same issue on the latest version of Chrome (52.0.2743.116 m (64-bit)). Doing this incognito so Chrome extensions shouldn't come into play...

@reddalek
4 years ago

#11 in reply to: ↑ 10 @azaozz
4 years ago

Replying to reddalek:

Looks like you're testing in WordPress 4.5 or a beta/RC? There was a bug (actually several separate cases) which prevented the link toolbar from hiding. They were all fixed and this is no longer a problem in 4.6.

Could you please confirm the WordPress version you're testing in, and also what browser you're using. I've seen some reports for intermittent errors in IE11 and Edge, but nothing that would leave the link toolbar open.

Last edited 4 years ago by azaozz (previous) (diff)

#12 @reddalek
4 years ago

I'm testing in Wordpress 4.6, where my original screenshots are from.

That latest screenshot is from someone else's demo site (http://demo.talkpress.de/trunk/) which I provided just to demonstrate it's not limited to my Wordpress installation. Its reported version is WordPress 4.6-beta1-37926. (Are you able to reproduce it yourself if you log in there on Chrome?)

Browser version is 52.0.2743.116 m (64-bit).

#13 @heidimark
3 years ago

Verified on WordPress 4.7.1. Windows 10 Home using Chrome 55.0.2883.87. However, Windows 10 Professional using the same browser did not produce the same results.

Last edited 3 years ago by heidimark (previous) (diff)

#14 @heidimark
3 years ago

Update to my last comment after further testing. We have narrowed down the issue to Windows 10 devices with touch capabilities enabled. If you disable the "HID-compliant touch screen" setting, the link editor functions correctly. With touch enabled, it does not.

So, the conflict appears to be between Windows 10 touch capabilities and whatever WordPress uses to show/hide the link editor.

#15 @desrosj
10 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

@heidimark @reddalek Sorry that this ticket was missed for so long. Are you still experiencing this issue? If so, can you please provide browser and operating system details/versions.

The Classic Editor is in high priority/major bug fix and regression only mode since the introduction of the new block editor in WordPress 5.0. Because of that, I am going to close this issue. However, please do reopen the ticket if you can still reproduce the bug. This is a bug fix I think can be considered if the behavior is still present and someone is willing to work on a fix because this could potentially hinder someone's ability to write their content.

Note: See TracTickets for help on using tickets.