WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#36659 closed defect (bug) (duplicate)

Add Media Not seleting when we are tab using keybord

Reported by: mynamevenu24 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5
Component: Posts, Post Types Keywords:
Focuses: accessibility, administration Cc:

Description

In edit page add media button not selecting while using tab, tab is going only edit and right sections only

Change History (4)

#1 @swissspidy
5 years ago

  • Component changed from General to Posts, Post Types
  • Focuses accessibility administration added

Can anyone confirm this is a regression in 4.5 and has been working properly before?

#2 @mynamevenu24
5 years ago

Getting same issue on previous version also, not selecting tab 'add media' button while using keyboard

This ticket was mentioned in Slack in #core by mynamvenu24. View the logs.


5 years ago

#4 @afercia
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks @mynamevenu24 this is a long standing accessibility issue already tracked in a previous ticket, see #29838

When you're in the "Title" field and then you tab forwards, focus is moved directly inside the editor area skipping all what's in between.

Currently, the only way to tab to the Add Media button is tabbing backwards from the Editor, pressing Shift + Tab. Hopefully there will be some consensus to improve all the area between the title and the editor. Please do feel free to follow the previous ticket and comment :) going to close this one as a duplicate.

Note: See TracTickets for help on using tickets.