WordPress.org

Make WordPress Core

Opened 2 years ago

Last modified 18 months ago

#36664 reopened defect (bug)

Input lag in text editor

Reported by: MarioKnight Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.5
Component: Editor Keywords:
Focuses: Cc:

Description

When editing a page with a lot of content, keystrokes appear on the screen very delayed from when they are pressed. This appears to be limited towards Chrome, as testing on other browsers yielded the instant visual expected. This feels similar to #32156 that I opened around this time last year which was solved between #32197 and a future version of Chrome. It seems that at some point in the last week or two, this issue has returned. Unlike the previous issue, this also occurs when the full-height editor is disabled. The jsfiddle used to test this ( https://jsfiddle.net/7vo8wteu/ ) doesn't show an issue as it did last year. I put in an issue at https://bugs.chromium.org/p/chromium/issues/detail?id=606156 on Saturday, and figured I'd post here as well just in case, given #36545 also being focused towards Chrome.

I confirmed this on my Windows 7 laptop with WordPress 4.5. I was hoping that #36545 was related to this and updated to 4.5.1-RC2, however the issue still persists.

Change History (5)

This ticket was mentioned in Slack in #core-editor by iseulde. View the logs.


20 months ago

#2 @iseulde
20 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Thanks for the ticket! Is this still an issue with the latest Chrome updates? Which editor is this, visual or text? Is autocorrect on (may cause lag with huge texts)? I'll close it for now as this seems to be a Chrome issue, but feel free to reopen if this is not correct.

#3 @azaozz
20 months ago

Tested in Chrome 53.0.2785.143 m on Win10. All seems to work well and reasonably fast. Actually the Text editor (textarea) is slower.

#4 @MarioKnight
20 months ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Summary changed from Input lag in Chrome 50.0.2661.87? to Input lag in text editor

Interestingly, though my issue submission to the Chrome dev team hasn't been updated in some time, the POC page I made to show them this is no longer showing the lag. So I decided to check on the page that was originally reported to me if this was no longer present there as well. Sadly, this is not the case. Similar to what @azaozz mentioned, the text editor tab still shows the lag. The visual editor tab seems to work with no issues. I only worked with the text editor tab myself, I would have to ask my friend if he noticed it there initially or at all. The lag exists regardless on if the full-height editor is enabled or disabled. I do not have any auto-correct extension in place.

I am currently using Chrome 53.0.2785.143 m on Windows 7, WordPress 4.6.1. I checked on Firefox 49.0.1 as well, and the behavior is the same (POC page tests seemingly fine, text editor tab shows lag). It appears that we failed to check Firefox back in April, likely because the first issue report was a Chrome-only issue, so I don't know how "new" this issue might be to Firefox.

Since this is still present and no longer seems to be browser-specific, I'll re-open this with a new summary label. Please let me know if there's anything else you would need from my end or have anything you'd like me to test out.

#5 @netweb
18 months ago

  • Milestone set to Awaiting Review

Moving reopened tickets without a milestone back to Awaiting Review for review

Note: See TracTickets for help on using tickets.