WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 6 months ago

#36683 closed defect (bug) (worksforme)

New Links with Text are not being inserted in visual editor for 4.5 and 4.5.1 versions

Reported by: irwinbraganza Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5.1
Component: TinyMCE Keywords:
Focuses: Cc:
PR Number:

Description

Links added in the editor for TEXT ALREADY PRESET in the following way works fine :
1) Double click on it / select the text portion which you want to be linked.
2) Click on Insert/Edit link button, A pop up will appear
3) Select/Insert the url in the URL input and click on Add Link

BUT if the links are added FOR NEW TEXT ADDED ALONG WITH THE LINK as follows it does'nt get added:
CASE 1:
1) Select the text, cut it and then click on the "Insert/Edit link" button, pop up will appear
2) Select/Insert the url in the "URL" input, Paste the text you had cut in step 1 in "Link Text" input and click on Add Link
CASE 2:
1) Move the cursor in the editor to where you want add a link
2) Now Click on the "Insert/Edit link" button, pop up will appear
3) Select/Insert the url in the "URL" input, insert the new text needed for the link in "Link Text" input and click on Add Link

The above two cases work perfectly fine for wordpress version before 4.5, But it doesnt work in 4.5 and 4.5.1 version

Attachments (1)

inlineEditorBug.mp4 (3.1 MB) - added by irwinbraganza 4 years ago.
video showing bug

Change History (13)

#1 @Clorith
4 years ago

Hi there, and welcome to Trac!

All 3 of these scenarios work fine for me, have you ensured you're not running any plugins and are using a default theme (such as Twenty Sixteen at this time)?

#2 @Clorith
4 years ago

  • Component changed from TinyMCE to Editor
  • Focuses javascript added; administration removed

@irwinbraganza
4 years ago

video showing bug

#3 @irwinbraganza
4 years ago

yes iv tried it disabling all plugins and on Twenty Sixteen theme jus now on 4.5.1... can you please check the video iv attached using my custom theme ?? might help you out.

Last edited 4 years ago by irwinbraganza (previous) (diff)

#4 @irwinbraganza
4 years ago

I have done a fresh install of wordpress 4.5.1 with twenty sixteen theme and repeated the steps done in the video => https://core.trac.wordpress.org/attachment/ticket/36683/inlineEditorBug.mp4 ... the issue does exist @Clorith ... Can you please check it out??

#5 @azaozz
4 years ago

  • Milestone changed from Awaiting Review to 4.6

I can reproduce it. Steps:

  • Add a new link (with or without cutting some text first) from the modal, both text and URL.
  • Without typing or clicking anywhere else in the editor, click on "Preview". The link is removed.

Happens as when a new link that is added from the modal, both text and URL, it is being inserted in the MCE caret placeholder span. If the caret is then moved inside the editor, that span is removed. However if the post is saved straight away, only the text content from there remains.

Working on a patch. For now the workaround is to click or type in the editor after adding a link in that manner.

#6 @ocean90
3 years ago

  • Keywords needs-patch added

#7 @azaozz
3 years ago

  • Milestone changed from 4.6 to Future Release

Looks like this will need a fix upstream. We can play a bit with focusing the editor/moving the caret but it's all pretty hacky. Ideally the link (or other new content) should be inserted next to the caret placeholder nodes as siblings, not inside them.

#8 @azaozz
3 years ago

  • Component changed from Editor to TinyMCE
  • Focuses javascript removed

#9 @azaozz
3 years ago

#37676 was marked as a duplicate.

#10 @azaozz
3 years ago

#37360 was marked as a duplicate.

#11 @azaozz
3 years ago

#36739 was marked as a duplicate.

#12 @azaozz
6 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Cannot reproduce any more, seems to be working properly in 5.2.

Note: See TracTickets for help on using tickets.