WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#36692 closed defect (bug) (duplicate)

Ajax requests should display errors

Reported by: avagoldin Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bootstrap/Load Keywords:
Focuses: Cc:

Description

This is a follow-up to #26262 and #36472

I don't really get why this change was added. It makes debugging really difficult now. If a theme or plugin breaks something (e.g. the Media Library #36472) it's the theme or plugin that needs to be fixed.

Change History (2)

This ticket was mentioned in Slack in #core by jorbin. View the logs.


4 years ago

#2 @jorbin
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #26262.

Thanks for the ticket @avagoldin.

Deciding to display or hide errors here is a balancing act between developer and user desires and in this case (as in many) WordPress sides with the user. In development environments, tools like query monitor can be used to ensure developers see errors while also preventing users from seeing a broken site.

Note: See TracTickets for help on using tickets.