Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#36719 closed defect (bug) (invalid)

get_post_meta

Reported by: pubblivori Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5.1
Component: Upgrade/Install Keywords: reporter-feedback
Focuses: Cc:

Description

After upgrade to 4.5.1 (from 4.4.2) the get_post_meta function stopped working.
I've made some tests with get_post_custom and seems working.

Change History (5)

#1 @sebastian.pisula
6 years ago

more information ?

#2 @pubblivori
6 years ago

I'm still doing some tests... but the fact is that a function using it stopped working after the upgrade...
I have to do te same reverse test into another site using the previous wp version. If the outuput is not the same.... something went wrong....

Here the piece of code isolated:

//$vecchia_scheda = get_post_meta( 68846, 'vecchia_scheda', true ); //not working after upgrade

$custom_fields = get_post_custom(68846);
$vecchia_scheda = $custom_fields['vecchia_scheda'][0];
//mod working

$vecchio_slug= get_post_field( 'post_name', $vecchia_scheda );
$nuovo_slug= get_post_field( 'post_name', $ID );

#3 @swissspidy
6 years ago

  • Keywords reporter-feedback added

get_post_meta() is used plenty of times in core and by many plugins out there. So far this is the first report about get_post_meta() not working anymore in 4.5. Hence I'm pretty sure it's not a bug in WordPress itself.

Does your problem still exist with all plugins disabled and using one of the default themes?

#4 @pubblivori
6 years ago

  • Resolution set to invalid
  • Status changed from new to closed

probable that is my problem.... since I'm not a developer and is hard to figure out what the problem is. the only thing I know that was running just before the upgrade...and after that no more...
I close this report by now.....thanyou for your patience....

#5 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted

Feel free to reopen with steps to reproduce on a clean install if it turns out to be a bug in WordPress core.

Note: See TracTickets for help on using tickets.