WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#36732 closed defect (bug) (fixed)

Inline Link Editor issue in Firefox and Chrome

Reported by: hardeepasrani Owned by: azaozz
Milestone: 4.6 Priority: normal
Severity: normal Version: 4.5
Component: Editor Keywords:
Focuses: javascript, administration Cc:
PR Number:

Description

We tested this on #forum channel and here's how to reproduce the issue and all the details we know.

  1. Open a new page/post and type some text. Use inline editor on text and it's working.
  2. After that select some other text and use inline editor but choose the Advanced options and use that.
  3. After that, finally, try to use inline editor again and clicking on Apply won't do anything.

Here's a screencast: http://pasteboard.co/BHaPgD6.gif

https://cdn.pbrd.co/images/BHaPgD6.gif

It's only happening in Firefox (tested in Windows 10 and Ubuntu - working just fine on Mac). Anyway, it will be great if you guys can test on other browsers. All the plugins were disabled, were using default theme.

Let me know if you need any more info. :)

Change History (10)

#1 @hardeepasrani
4 years ago

  • Component changed from General to TinyMCE

#2 @Clorith
4 years ago

  • Component changed from TinyMCE to Editor
  • Focuses javascript added
  • Version changed from trunk to 4.5

#3 @penguinswander
4 years ago

  • Summary changed from Inline Link Editor issue in Firefox to Inline Link Editor issue in Firefox and Chrome

This is happening to me in Chrome. Until I watched above I didn't know to highlight the text, then add the url and hit enter. I was entering in the url first and then going into the advanced part to add the label. So most definitely not just a Firefox problem. I only was managing to get maybe 1 in 10 links to work.

#4 @Clorith
4 years ago

What versions of Chrome, we've been testing this for some time and only FireFox has been coming up with te symptoms while IE, Chrome etc. have all been behaving as expected.

#5 @hardeepasrani
4 years ago

@penguinswander Could you tell give us some details, like:

  • Your operating system.
  • Browser version.
  • Could you try and see if it works in the Private window?
  • Also - could you try after deactivating all the plugins?

Thank you. :)

#6 follow-up: @jetjockey
4 years ago

Re: Insert/edit link function not working on static page in WP4.5.2 Visual editor

I’m brand new to WP, but I cannot get the Insert/edit link function to work on a “static page” in WP4.5.2 Visual editor.

The Insert/edit link function does not create an “active link” that will branch to another page.

I’m using Mac OS X, Chrome v49.0.2623.112 as the browser, and WP-Drudge as the theme.

I also tried Firefox v47.0 and Safari browsers. The Insert/edit link option doesn’t work there either.

Background info:
I have a static page that is accessed from my homepage’s navigation menu.

The static page has excerpts (2 paragraphs) from seven different articles. At the end of each excerpt, I want to place a “continue reading” link that branches to a static page with the entire story. That means there would be a total of 7 “continue reading” links on the static page, one for each of the 7 excerpts.

My basic question is: In WP 4.5.2, how do I insert a link on a static page that branches to another static page?

My steps:

  • I start in the static page Visual Editor.
  • I click on the Insert/edit link located in the editor’s top menu.
  • Click on the gear wheel
  • Click on a “recent item” that places a destination link into the URL window
  • I type in “Continue reading” into the Link Text window.
  • I click the blue “Add link” button
  • An underlined “continue reading” link appears at the end of the first article excerpt.

Note: at this point, the link looks like it is active.

  • I click the blue “Update” button.
  • After the page refreshes, a “continue reading” link appears at the end of the first article’s excerpt; however, it is not underlined or active. The link text is just grayed out like all of the excerpt text. The link doesn’t branch to the appropriate static page.

Also, I have two active plugins, so I deactivated both of them, but the Insert/edit link function still won’t work.

Does anyone have any ideas as to what’s going on?

Am I implementing the Insert/edit link incorrectly, is there a bug in WP 4.5.2, do I need some CSS code, or…..?

I have heard about significant problems with the “Insert/edit link” function and also the “read more” tag function in recent WP updates.

Additionally, I have also read rumors that the problem “may” be associated only with “static pages” and not “posted pages.”

Not to confuse the issue, but here’s one more piece of info:
Early this morning, I actually got the Insert/edit link function to work, but only once. I applied it to the first article’s excerpt and Insert/edit link worked, it branched to another page. Then, when I tried to implement the feature on the other 6 excerpts it wouldn’t work.

In fact, this problem sounds like the Known Problem Ticket# 36732.

Does any one have a go-around fix for this problem?

Any help would be appreciated.

#7 in reply to: ↑ 6 @hardeepasrani
4 years ago

Replying to jetjockey:

Please keep support related questions in the support forum, as you've posted here: https://wordpress.org/support/topic/insertedit-link-function-not-working-on-static-page-in-wp452-visual-editor?replies=1

It will just confuse the developers more. :)

#8 @somethingelse
3 years ago

this is still a thing in chrome (wp 4.5.2, win 8.1)
Site that triggered me to come here is using Adventurous theme - highly customized, and probably a couple too many plugins :) Off the top of my head i'm not sure if it's happened on any other sites.

it generally works fine unless i click the gear to go to advanced. when i click "add link" it closes back down to the inline editor, and then that does nothing. And it won't go away.

Entering a url it just keeps clearing and not linking anything to anything.
I have to click the UNLINK icon in editing tools to make it go away and then start over.
Not the end of the world, but definitely annoying. Just having the "open in new window" checkbox visible in the inline tool would make a world of difference to workflow. It's a lot more steps now, it feels like...

thank you for all you do!

#9 @azaozz
3 years ago

  • Milestone changed from Awaiting Review to 4.6

Related, or maybe a duplicate of #36781. The symptoms are different but the bug is with not resetting the state.

#10 @azaozz
3 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 37906:

TinyMCE, inline link dialog:

  • Reset the internal state when doing unlink, pressing Escape, and clicking elsewhere in the editor.
  • Add the unlink shortcut from the wplink plugin as it triggers the new wp_unlink command.

Fixes #36781, #36732, #37153.

Note: See TracTickets for help on using tickets.