WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#36747 closed defect (bug) (invalid)

Virtual robots.txt adds detected sitemap http:// not https://

Reported by: jeffmcneill Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

This is for the SSL/HTTPS, if a sitemap.xml or sitemap.xml.gz is detected at the root of the website, an entry into the virtual robots.txt is made.

However, even on an https/ssl site (where the sitemap.xml has the SSL protocol listed inside it as the site, as well as the site itself having https:// in both display and url), a plain http:// URL is generated.

Change History (4)

#1 @jeffmcneill
4 years ago

Note that the work-around is to move the sitemap to a subdirectory, and then this automated behavior of adding the sitemap is disabled.

#2 @pento
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 4.5.1 deleted

Thanks for the bug report, @jeffmcneill!

WordPress doesn't add sitemap.xml to the default robots.txt file, so it seems like this is being caused by a plugin. I'd recommend you try disabling your plugins one by one, until you discover which one is adding this line, then contacting the plugin author.

#3 @jeffmcneill
4 years ago

Ah, yes, I found it. Sorry for the bother. I've notified the plugin author of the issue.

#4 @pento
4 years ago

No problem, thanks for checking in! You're always welcome to open a ticket, we'd prefer to take a few minutes to investigate a potential problem, than not know about it in the first place. :-)

Note: See TracTickets for help on using tickets.