WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#36769 closed defect (bug) (duplicate)

I can't find the accessibility option for the widgets page

Reported by: willsworldwv Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Widgets Keywords:
Focuses: ui, accessibility Cc:

Description

Ever since the update to the latest version, there is no accesibility option for the widgets page. Like the screen settings to turn on accessibility mode.

Attachments (2)

widgets-screen-options.png (50.9 KB) - added by westonruter 4 years ago.
screenshot.jpg (240.8 KB) - added by willsworldwv 4 years ago.
Screen Shot of Widget page / area

Download all attachments as: .zip

Change History (13)

#1 @DrewAPicture
4 years ago

  • Focuses accessibility added; multisite removed
  • Type changed from feature request to defect (bug)

#2 @westonruter
4 years ago

  • Keywords reporter-feedback added

@willsworldwv I just checked 4.5.1 and I see the widgets accessibility mode available under screen options where I remember seeing it before. (See screenshot above.)

Last edited 4 years ago by westonruter (previous) (diff)

#3 @willsworldwv
4 years ago

I still do not see a button for screen options. How do I get to it?

@willsworldwv
4 years ago

Screen Shot of Widget page / area

#4 @willsworldwv
4 years ago

That is a screen shot of what I see in the Widget area page. No Screen options button to turn on accessibility mode

#5 @SergeyBiryukov
4 years ago

Related/duplicate: #36123

#6 follow-up: @afercia
4 years ago

  • Focuses ui added
  • Keywords needs-patch added; reporter-feedback removed

To clarify, this happens because the page is zoomed by the browser at 175% and the "responsive view" kicks in changing the layout and the display of all the admin screens. The exact zoom level the responsive view kicks in at may vary depending on the screen size and resolution, for example on the laptop I'm using right now I have to zoom at 200%. In the responsive view, the Screen Options and Help tabs are hidden, see #36123 as pointed out by @SergeyBiryukov :)

From an accessibility point of view, worth considering many people do zoom the pages so it would be better to don't hide important controls in the responsive view. A quick fix would be adjusting the CSS media query but I'd recommend to re-think these two tabs and try to improve them.

@willsworldwv as a temporary workaround you could try to zoom out at 150% or 125% and these two tabs should re-appear, set accessibility mode and then zoom in again.

#7 @afercia
4 years ago

  • Version 4.5.1 deleted

#8 in reply to: ↑ 6 @SergeyBiryukov
4 years ago

Replying to afercia:

From an accessibility point of view, worth considering many people do zoom the pages so it would be better to don't hide important controls in the responsive view. A quick fix would be adjusting the CSS media query but I'd recommend to re-think these two tabs and try to improve them.

Related/duplicate: #21583 :)

#9 @willsworldwv
4 years ago

I zoomed my browser down to 100% and it fixed the issue.
Thank you for all your help. It is greatly appreciated.

#10 @willsworldwv
4 years ago

  • Status changed from new to closed

#11 @swissspidy
4 years ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate

Duplicate of #36123.

Note: See TracTickets for help on using tickets.