WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#36805 closed defect (bug) (invalid)

Deprecated: mysql_connect(): error code

Reported by: dekkertjie Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/mdekkertjie/public_html/wp-includes/wp-db.php on line 1520

Change History (2)

#1 @knutsp
6 years ago

  • Keywords close added

Hello @dekkertjie and welcome to Trac.

This message is given when you are running on PHP 5.5 or 5.6 without the mysqli extension. This forces WordPress to use the deprecated mysql extension when connecting to the database. This not a bug in WordPress.

My advice would be to contact your host and get mysqli included in their PHP.

#2 @pento
6 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 4.5.2 deleted

Please also confirm that WP_USE_EXT_MYSQL is not set in your wp-config.php file. If it is, you'll need to remove that setting.

Note: See TracTickets for help on using tickets.