WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

#3685 closed defect (bug) (invalid)

2.1 Lost post on publish

Reported by: tandilboy Owned by:
Milestone: Priority: high
Severity: critical Version: 2.1
Component: Administration Keywords: data-loss
Focuses: Cc:

Description

create a post -> if i not assign any category and press publish, wordpress redirects to main post page and loses the post

Change History (16)

comment:1 @Viper007Bond8 years ago

  • Component changed from General to Administration
  • Milestone 2.1.1 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Unable to reproduce. Disable all plugins and try again.

If it's still doing it, please provide more details (server configuration, etc.).

comment:2 @tandilboy8 years ago

  • Milestone set to 2.1.1
  • Resolution worksforme deleted
  • Status changed from closed to reopened

i using PHP version: 5.0.4 mySQL version: 5.0.22-max

when i create a post, the default category isnt appear checked. and happens this

comment:3 @MichaelH8 years ago

Even though the Write Post screen shows no Category checked, the Post does get written with the Category specified in Options->Writing->Default post category.

Even so, the box should be checked in the Write Post screen.

Screenshot showing unchecked Category

comment:4 @ryan8 years ago

Now checking the default category is expected behavior for 2.1. Not checking it was a popular request that we decided to try out.

As for the problem with redirecting and losing the post, I cannot reproduce and have not seen any other mentions of this. Strange indeed.

comment:5 @ryan8 years ago

s/Now/Not/

comment:6 @johnbillion8 years ago

I have reproduced this bug, somewhat unintentionally.

I created 12 posts one after the other without setting the category on any, and 2 out of 12 did not publish after hitting the Publish button and returned to page-new.php and lost the post.

Brand new fresh install of 2.1, no plugins, PHP 5.1.4, MySQL 4.1 .

comment:7 @markjaquith8 years ago

The reasoning behind leaving the default category unchecked at first was this:

  • Default means fallback, not "something that continues to be the case when a preference has been made"
  • Many people reported being frustrated by the behavior of checking the default behavior, as many of their posts ended up being categorized in the default category

Don't know what to say about the losing posts bug, but I'd be very surprised if it had anything to do with not having a category checked. I'll test.

comment:8 @foolswisdom8 years ago

  • Keywords data-loss added
  • Priority changed from high to highest omg bbq
  • Severity changed from major to blocker
  • Summary changed from default category for posts isn´t work to 2.1 Lost post on publish

Looking at the code, even my layperson skills, it seems unlikely that the cause is not setting the category in the UI.

tandiboy, does this reproduce every time? As ziper asked can you provide more details about your env?

johnbillion, in discovering this where you testing for this scenario or real blogging? How long before each publish (any chance long enough for auto-save trigger). Any more clues on reproducing? (I have not yet been able to reproduce.

comment:9 @tandilboy8 years ago

ok i explain the issue
in 2.0.7 version when i click in "Write Post" open this page and shows the default category checked. works good

in 2.1 when i click in "Write Post" open this page, and not shows the default category checked. when i write the post an press in "Publish" lose the post and returns to page-new.php

simple

comment:10 @foolswisdom8 years ago

tandilboy, in 2.1 you can reproduce every time that the post is lost?

comment:11 @tandilboy8 years ago

wordpress 2.0.7 works well

the version 2.1 had that error. the system dont show any php level error. when i press "publish" the page shows as i press the "create new post" page and lose the post

I using http://wordpress-es.sourceforge.net/ language for wordpress

comment:12 @Nazgul8 years ago

  • Milestone changed from 2.1.1 to 2.1.2

2.1.1 is out, so bumping the milestone to 2.1.2.

Although fixing this one will be hard without a solid reproduction case.

comment:13 @johnbillion8 years ago

Sorry about not responding quicker on this. For the above I was crash testing WordPress on a test installation.

I tried this again just now on another clean install of 2.1, and out of 50 posts one got lost (the 8th post). It certainly doesn't happen often and I haven't been able to reproduce it on 2.0.9 (tried 50 posts again and it all worked fine).

My suspicion is that it might not even be to do with WordPress. It could even be an issue with my server not being able to write to the database for one reason or another.

comment:14 @darkfate8 years ago

Maybe it's a memory issue with PHP? Just throwing stuff out there. If there was a problem with wordpress, it would happen every time. Unless it has to do with what is contained within the post (maybe TinyMCE does something we don't want it to do).

comment:15 @foolswisdom8 years ago

  • Milestone changed from 2.1.3 to 2.4
  • Priority changed from highest omg bbq to high
  • Severity changed from blocker to critical

No success isolating the problem, pushing out.

comment:16 @johnbillion7 years ago

  • Milestone 2.4 deleted
  • Resolution set to invalid
  • Status changed from reopened to closed

No movement in 9 months and I'm unable to reproduce this on 2.3.1 or trunk at r6365 using the same server I originally used to reproduce, so closing as invalid.

Note: See TracTickets for help on using tickets.