WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#36864 closed defect (bug) (invalid)

"No Follow" button Post Editor Bug

Reported by: fitpumps Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5.2
Component: Posts, Post Types Keywords: reporter-feedback
Focuses: Cc:

Description

When I change one link to no-follow, WordPress is automatically changing ALL links in my posts to no-follow. This includes my internal links, resulting in pingbacks and comments. I’ve tried to check/uncheck the box, manually add the no-follow tag, but it seems that by default it updates every link.

I have version 4.5.2. The box is located below the "open link in new tab" under link options.

The link button in general doesn't even work sometimes.

Change History (5)

#1 @ocean90
4 years ago

  • Keywords reporter-feedback added

Hello @fitpumps, welcome to this Trac!

Thanks for your report. WordPress doesn't include this option per default. Do you have any SEO plugins active? Does it still happen with all plugins disabled and a default theme activated?

#2 follow-up: @lukecavanagh
4 years ago

WordPress by default does not have any SEO built in other than the Search Engine Visibility in Reading Settings. Which SEO Plugin is active on the site?

#3 in reply to: ↑ 2 @fitpumps
4 years ago

Replying to lukecavanagh:

WordPress by default does not have any SEO built in other than the Search Engine Visibility in Reading Settings. Which SEO Plugin is active on the site?


We use Yoast.

#4 @lukecavanagh
4 years ago

  • Keywords close added

So this seems like not a WP core issue, but a Yoast SEO issue. There is a fix for that Yoast SEO issue. Just add this code snippet into your active theme functions.php file.

https://gist.github.com/lukecav/7de2f731d14618f1702e

#5 @joostdevalk
4 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

WordPress core doesn't have a nofollow link option in 4.5.2. Yoast SEO doesn't add it either... Closing as invalid.

Note: See TracTickets for help on using tickets.