WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#36876 closed defect (bug) (fixed)

TinyMCE: inline toolbars don't adjust position

Reported by: iseulde Owned by: iseulde
Milestone: 4.5.3 Priority: normal
Severity: normal Version: 4.5
Component: TinyMCE Keywords: has-patch fixed-major
Focuses: javascript Cc:

Description

Inline toolbars no longer adjust position after scrolling.
git bisect shows me it's introduced in [37000].

Attachments (2)

36876.patch (752 bytes) - added by iseulde 4 years ago.
36876.2.patch (1.2 KB) - added by iseulde 4 years ago.

Download all attachments as: .zip

Change History (15)

#1 @iseulde
4 years ago

When I scroll the event type is now resizewindow (Chrome, Firefox and Safari).
https://github.com/tinymce/tinymce/commit/5734a8d8805d69ee87dd1cad7263244968194601

Last edited 4 years ago by iseulde (previous) (diff)

@iseulde
4 years ago

#2 @iseulde
4 years ago

  • Keywords has-patch needs-testing added; needs-patch removed

This ticket was mentioned in Slack in #core-editor by iseulde. View the logs.


4 years ago

@iseulde
4 years ago

#4 @iseulde
4 years ago

  • Owner set to iseulde
  • Resolution set to fixed
  • Status changed from new to closed

#5 @iseulde
4 years ago

  • Keywords fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Consider for 4.5.x.

This ticket was mentioned in Slack in #core-editor by iseulde. View the logs.


4 years ago

#7 @adamsilverstein
4 years ago

  • Keywords commit added; needs-testing removed

#8 @adamsilverstein
4 years ago

  • Keywords needs-testing added; commit removed

#9 @adamsilverstein
4 years ago

@iseulde does this still need testing? can you describe how to test or provide screen shot(s) to show what the issue is?

Thanks!

#10 @iseulde
4 years ago

  • Keywords needs-testing removed

Well, needs no more testing than the usual. :)

Before the inline toolbar would not adjust when scrolling. For example, select an image so that an inline toolbar pops up, then scroll and you'll see that the toolbar will overlap the main toolbar instead of adjusting its position. Note that this only affected the full height editor (see Screen Options > Additional settings).

This ticket was mentioned in Slack in #core by adamsilverstein. View the logs.


4 years ago

#12 @adamsilverstein
4 years ago

Great, thanks for clarifying. I had removed the 'needs-testing' tag because you had committed then realized I should double check to make sure that was right.

#13 @ocean90
4 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.