WordPress.org

Make WordPress Core

#36880 closed defect (bug) (fixed)

Correct @link in /wp-includes/cache.php

Reported by: michaelbeil Owned by: DrewAPicture
Milestone: 4.6 Priority: normal
Severity: normal Version: 2.6
Component: Cache API Keywords: has-patch
Focuses: docs Cc:

Description

Attachments (2)

36880.diff (395 bytes) - added by michaelbeil 10 months ago.
36880.2.diff (392 bytes) - added by michaelbeil 10 months ago.

Download all attachments as: .zip

Change History (7)

@michaelbeil
10 months ago

#1 @swissspidy
10 months ago

I assume you mean https://codex.wordpress.org/Class_Reference/WP_Object_Cache? :)

The problem is that the file doesn't just contain the class, but also the helper methods. We should really split this up.

After that, the docblock can be adjusted accordingly.

#2 @michaelbeil
10 months ago

Yea, @swissspidy, that is exactly what I meant :). I updated the diff accordingly.

What would be the best way of splitting this up?

WP_Object_Cache is both not a function and not WP_Cache.

#3 @DrewAPicture
10 months ago

  • Focuses docs added
  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 4.6
  • Owner set to DrewAPicture
  • Status changed from new to reviewing

#4 @DrewAPicture
10 months ago

In 37460:

Docs: Fix an incorrect Codex link in the file header for wp-includes/cache.php.

Introduced in [7990].

Props michaelbeil.
See #36880.

#5 @DrewAPicture
10 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

@swissspidy Let's close this as fixed for the single issue.

I'd venture to guess that the reason why we've left cache.php alone is that it can still be directly preempted by an object-cache.php drop-in.

Note: See TracTickets for help on using tickets.