WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#36950 closed enhancement (duplicate)

Get term by should use get_terms internally

Reported by: spacedmonkey Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.3
Component: Taxonomy Keywords:
Focuses: performance Cc:
PR Number:

Description

Now that WP_Term_Query has been merged, it makes sense to converge to use it in all internal functions to query the terms table. Using WP_Term_Query / get_terms will also add caching to a functions that do not currently have it.

Attachments (1)

36950.patch (2.1 KB) - added by spacedmonkey 3 years ago.

Download all attachments as: .zip

Change History (2)

@spacedmonkey
3 years ago

#1 @boonebgorges
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21760.

Previously: #13170.

I raised this proposal in https://core.trac.wordpress.org/ticket/21760#comment:87. Let's move the discussion there.

Note: See TracTickets for help on using tickets.