WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#36959 closed defect (bug) (invalid)

Clicking Add site fast enough adds same site twice

Reported by: pauldewouters Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Networks and Sites Keywords: good-first-bug reporter-feedback
Focuses: ui, accessibility, multisite Cc:
PR Number:

Description

On the wp-admin/network/site-new.php admin page, if you click Add site fast enough, like a double click, it will add the same site twice.

Change History (12)

#1 @lukecavanagh
3 years ago

So would you want a delay before another site would be added or to check if that site already exists?

#2 follow-up: @johnbillion
3 years ago

  • Component changed from Administration to Networks and Sites
  • Focuses multisite added
  • Keywords needs-patch added
  • Version changed from 4.5.2 to 3.0

Ideally the 'Add Site' button would disable itself in the same way the 'Update' button disables itself on the post editing screen.

#3 @DrewAPicture
3 years ago

  • Focuses ui accessibility added

#4 in reply to: ↑ 2 @pauldewouters
3 years ago

Replying to johnbillion:

Ideally the 'Add Site' button would disable itself in the same way the 'Update' button disables itself on the post editing screen.

I wholeheartedly support this suggestion

#5 @jeremyfelt
3 years ago

  • Keywords good-first-bug added
  • Milestone changed from Awaiting Review to 4.6

There's some prior art in core for this. Seems like a good first bug candidate.

#6 follow-up: @canship
3 years ago

I setup a test environment locally and no matter how quickly I double click I just get a validation that the site already exists.

Does anyone know if this is still possible to duplicate?

#7 in reply to: ↑ 6 @afercia
3 years ago

Replying to canship:

Does anyone know if this is still possible to duplicate?

I've tested a few days ago and couldn't reproduce. Always get the "site already exist" notice. Using a sub-domain install.

#8 @scottbasgaard
3 years ago

Unable to replicate this either.

Have tried reproducing a few different ways and always get "Sorry, that site already exists!" as well.

@pauldewouters anything we might be missing here?

#9 @afercia
3 years ago

  • Keywords reporter-feedback added; needs-patch removed

#10 @pauldewouters
3 years ago

well, I'm not able to reproduce it anymore. it must have been a very specific configuration that made it possible.

This ticket was mentioned in Slack in #core by canship. View the logs.


3 years ago

#12 @netweb
3 years ago

  • Milestone 4.6 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Let's close this, if anyone does reproduce feel free to re-open and add it to the "Awaiting Review" milestone.

Note: See TracTickets for help on using tickets.