Make WordPress Core

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#3697 closed defect (bug) (worksforme)

Incorrect links on Page Management screen

Reported by: johnbillion Owned by:
Milestone: Priority: low
Severity: normal Version: 2.1
Component: Administration Keywords: manage pages permalinks
Focuses: Cc:

Description

Under Manage -> Pages, the 'View' links are functional but do not adhere to the permalink structure defined under Options -> Permalinks.

Too see it in action:

  1. Go to Manage -> Pages
  1. Hover over a 'View' link on one of your pages and you'll see that although the link points to the page it does not adhere to the permalink structure, eg. the page points to example.com/?page_id=7 instead of example.com/about/

Change History (5)

#1 @Viper007Bond
15 years ago

Works fine for me...

Disable all plugins and try again.

#2 @johnbillion
15 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Ok I fixed this by going into Options -> Permalinks, changing my permalinks to something else, then changing them back. Maybe something didn't work quite right the first time I changed my permalinks.

#3 @foolswisdom
15 years ago

johnbillion, had you recently set or changed your permalinks? Was this an upgrade or new installation of WP? Any other clues?

#4 @markjaquith
15 years ago

Positive that this is with version 2.1 and not /trunk/ (2.2) ?

#5 @johnbillion
15 years ago

Definitely 2.1 from wp.org/download. Clean fresh install. I had changed my permalinks a day or so before so I'm guessing this is where the problem was. Unable to reproduce this again though.

Note: See TracTickets for help on using tickets.