WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#36986 closed defect (bug) (duplicate)

Month translations combined into each other

Reported by: honza.kopecky Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4
Component: I18N Keywords:
Focuses: Cc:

Description

We are using .mo file to translate months to Czech language.

Czech has two forms for July. When you say "July" it is "Červenec" but when you say "17. July" then the translation is "17. Července" (check out the spelling). So in the .mo file there are two translations for both of the versions of the word.

This works pretty well for all months except July. For some strange reason Wordpress combines these two translations into one and outputs "Červnaec". I've ensured there is no typo in translation file.

When I change the "Červenec" translation to something longer or shorter everyting works just fine.

Here is the translation .po file we use on our website: http://www.hubostrava.cz/wp-content/languages/cs_CZ.po.

I tried to update Wordpress to 4.5.2 but it didn't change a thing.

Change History (2)

#1 @ocean90
3 years ago

  • Component changed from Date/Time to I18N
  • Focuses ui accessibility removed
  • Milestone Awaiting Review deleted
  • Version changed from 4.4.2 to 4.4

Hello @honza.kopecky, welcome to the WordPress Trac!

Thanks for your report. We're already tracking this issue in #36790.

#2 @ocean90
3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #36790.

Note: See TracTickets for help on using tickets.