WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#36987 closed defect (bug) (duplicate)

WordPress Importer: bump_request_timeout needs $val

Reported by: kraftbj Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Import Keywords:
Focuses: Cc:
PR Number:

Description

Error message:
WP_Import::bump_request_timeout() should be compatible with WP_Importer::bump_request_timeout($val) in /var/www/web78/htdocs/wp-content/plugins/wordpress-importer/wordpress-importer.php on line 38

Reported in https://wordpress.org/support/topic/error-message-when-plugin-activated-1?replies=2#post-8473678

Core's WP_Importer class has public function bump_request_timeout( $val ) in https://core.trac.wordpress.org/browser/trunk/src/wp-admin/includes/class-wp-importer.php#L219

The WP Importer's WP_Import extended class does not, only bump_request_time() in https://plugins.trac.wordpress.org/browser/wordpress-importer/tags/0.6.1/wordpress-importer.php#L1110

While 0.6.1 is stable, there was a 0.6.2 that was stable for a short time ( cc: @otto42 ) that included it https://plugins.trac.wordpress.org/browser/wordpress-importer/tags/0.6.2/wordpress-importer.php#L1124

Change History (2)

#1 @ocean90
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #24373.

See also:

#12619
A few fixes to the WordPress importer
#24373
WordPress Importer - Strict Standards compatibility
#26729
Two notices on Import page
#31707
Errors on Wordpress import
#32959
have error after installed WP_Importer
#32960
Wordpress Importer - already defined constructor for class WXR_Parser_Regex
#36987
WordPress Importer: bump_request_timeout needs $val


#2 @kraftbj
3 years ago

Thanks. I looked through the Import tickets, but didn't search specifically enough.

It would be nice to figure out a better way to support and keep updates moving forward for the Importers. The fix was pushed 3 years ago :-(

[EDIT: The issue got to me because individual wrote in to Jetpack support asking if we had a suggestion for a maintained importer.]

Last edited 3 years ago by kraftbj (previous) (diff)
Note: See TracTickets for help on using tickets.