WordPress.org

Make WordPress Core

Opened 14 years ago

Closed 14 years ago

#3703 closed defect (bug) (fixed)

Missing JS File: /wp-includes/js/scriptaculous/wp-scriptaculous.js

Reported by: docwhat Owned by:
Milestone: 2.1.1 Priority: normal
Severity: normal Version: 2.1
Component: General Keywords: scriptaculous javascript js script-loader
Focuses: Cc:

Description

It appears that the file /wp-includes/js/scriptaculous/wp-scriptaculous.js is missing. It is called from line 25 of the script-loader.php file.

This seems related to bug #3519 and was fixed in changeset [4813] in trunk *after* the 2.1 release.

Normally, this only impacts the admin interface. However, if a theme or plugin uses scriptaculous, then it causes lots of 404 errors and can cause the javascript to fail or misbehave in strange ways.

Ciao!

Change History (4)

#1 @error
14 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of bug 3519.

#2 @docwhat
14 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

This isn't a duplicate of 3519. I was not clear on IRC...

Attempt to describe the problem again:

This line tries to load wp-scriptaculous.js as JavaScript: source:/tags/2.1/wp-includes/script-loader.php@HEAD#L25
However, in the 2.1 release, wp-scriptaculous.js is missing: source:/tags/2.1/wp-includes/js/scriptaculous

Note the 'wp-' part of the filename. It's a customized version of scriptaculous.js to work around a loading problem.

Workarounds:

Change line 25 to use the scriptaculous.js file or go grab wp-scriptaculous.js from trunk.

Ciao!

#3 @error
14 years ago

That's a bit more clear... There seem to be two nearly identical files scriptaculous.js and wp-scriptaculous.js here. Maybe there should only be one?

#4 @ryan
14 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [4823]) Add wp-scriptaculous.js. fixes #3703 #3519

Note: See TracTickets for help on using tickets.