WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#37083 closed defect (bug) (duplicate)

Travis CI fails with latest PHP 7.1 nightly and latest WP

Reported by: Dogen Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5.2
Component: General Keywords:
Focuses: Cc:
PR Number:

Description

$ php --version
PHP 7.1.0-dev (cli) (built: Jun 12 2016 22:48:11) ( ZTS )

.[Mon Jun 13 00:24:29 2016] PHP Warning: Illegal string offset 'remember' in /tmp/wordpress/wp-includes/user.php on line 41
[Mon Jun 13 00:24:29 2016] PHP Stack trace:
[Mon Jun 13 00:24:29 2016] PHP 1. {main}() /tmp/wordpress/router.php:0
[Mon Jun 13 00:24:29 2016] PHP 2. require_once() /tmp/wordpress/router.php:51
[Mon Jun 13 00:24:29 2016] PHP 3. wp_signon() /tmp/wordpress/wp-login.php:784
[Mon Jun 13 00:24:29 2016] PHP Warning: Cannot assign an empty string to a string offset in /tmp/wordpress/wp-includes/user.php on line 41
[Mon Jun 13 00:24:29 2016] PHP Stack trace:
[Mon Jun 13 00:24:29 2016] PHP 1. {main}() /tmp/wordpress/router.php:0
[Mon Jun 13 00:24:29 2016] PHP 2. require_once() /tmp/wordpress/router.php:51
[Mon Jun 13 00:24:29 2016] PHP 3. wp_signon() /tmp/wordpress/wp-login.php:784
[Mon Jun 13 00:24:29 2016] PHP Warning: Illegal string offset 'user_login' in /tmp/wordpress/wp-includes/user.php on line 56
[Mon Jun 13 00:24:29 2016] PHP Stack trace:
[Mon Jun 13 00:24:29 2016] PHP 1. {main}() /tmp/wordpress/router.php:0
[Mon Jun 13 00:24:29 2016] PHP 2. require_once() /tmp/wordpress/router.php:51
[Mon Jun 13 00:24:29 2016] PHP 3. wp_signon() /tmp/wordpress/wp-login.php:784
[Mon Jun 13 00:24:29 2016] PHP Fatal error: Uncaught Error: Cannot create references to/from string offsets in /tmp/wordpress/wp-includes/user.php:56

Change History (2)

#2 @dd32
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Although a slightly different entry route, I'm still marking this as a duplicate of #37071 as it's the same root cause that is likely needing to be fixed in multiple locations.

Note: See TracTickets for help on using tickets.