WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#37084 closed enhancement (wontfix)

Image Alt tag by default

Reported by: garethgillman Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: Media Keywords:
Focuses: accessibility Cc:
PR Number:

Description

This has irked me for many years with WP and I believe this should finally be "fixed"...

Image alt tags are a necessary evil when adding images to a website as they are used to:

  • display something when an image can't load
  • for screen readers
  • for seo purposes (lightly)

Now at the moment we have to manually create an alt tag for every image we upload to WP but the title tag is automatically filled out.... so how difficult would it be to do the same for the ALT tag?

https://wordpress.org/plugins/seo-image/ does this but that's just another plugin for something so simple that should have been in core (imho).

As a developer I always add alt tags to my images but my clients don't and then it's normally down to me to use the mentioned plugin to "fix" this issue.

p.s. searched extensively and can't find any other topics on this

Change History (3)

#2 @joedolson
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

This won't happen. The problem is that automatically adding an alt attribute requires some kind of reliable source for that data - the image title is the source for existing automatic attributes, and it's fine for filling in a title field that's used only for managing the images, but it's entirely inappropriate for automatically filling in an alt attribute. For accessibility reasons, it's worse to have a bad alt attribute than to have none.

There's a plug-in called WP Accessibility (https://wordpress.org/plugins/wp-accessibility/) that will require users to add an alt attribute or declare an image as presentation when inserting an image that you can use if you want to make sure that happens.

Automated tools that insert alt attributes are almost never going to provide usable, accessible information.

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


3 years ago

Note: See TracTickets for help on using tickets.