WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#37120 closed defect (bug) (duplicate)

tag taxonomy not working with custom post type properly.

Reported by: gk.loveweb Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Taxonomy Keywords:
Focuses: ui, administration Cc:

Description

I have registered 'post_tag' taxonomy with custom news post type , now in

localhost/wp-admin/edit.php?post_type=news

page, when I'm trying to browse the posts using any tag

localhost/wp-admin/edit.php?post_type=news&tag=any_tag

It lists out the all posts from all custom post type which has that tag,but it should list the only posts of 'news' post type.

Change History (4)

#1 @theMikeD
3 years ago

Does it also show posts that use that tag?

When you go here

localhost/wp-admin/edit.php?tag=any_tag

does it show the CPT entries?

Version 0, edited 3 years ago by theMikeD (next)

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


3 years ago

#3 @afercia
3 years ago

  • Focuses accessibility removed
  • Version 4.5.2 deleted

Not strictly related to accessibility, removing the focus :) Also, the version should be set to the WP version the bug was introduced, when it is possible to track that.

#4 @SergeyBiryukov
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @gk.loveweb, thanks for the ticket!

This has come up before in #14076, #14084, and #20708, let's continue the discussion in the first ticket.

Note: See TracTickets for help on using tickets.