WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#37126 closed defect (bug) (fixed)

Shiny Updates: plugin updates fail from the update-core.php details modal

Reported by: afercia Owned by: swissspidy
Milestone: 4.6 Priority: high
Severity: normal Version: 4.6
Component: Upgrade/Install Keywords: has-patch
Focuses: javascript Cc:
PR Number:

Description

To reproduce, go in update-core.php:

  • click the "View version details" link on any available plugin update
  • the details modal opens
  • click the "Install Update Now" button
  • nothing happens, the browser console reports a JS error

https://cldup.com/57EOl9W2a0.png

On Firefox, the error message is a bit more clear and it says that $message is undefined.

Quickly looking at the updates.js code, maybe when clicking on '#plugin_install_from_iframe' the check for the 'update-core.php' window parent should be reintroduced when returning early before event.preventDefault().

Attachments (1)

37126.diff (454 bytes) - added by Nikschavan 4 years ago.
Revert github commit from shiny updates plugin - https://github.com/obenland/shiny-updates/pull/165

Download all attachments as: .zip

Change History (6)

#1 @swissspidy
4 years ago

  • Component changed from Plugins to Upgrade/Install
  • Owner set to swissspidy
  • Status changed from new to assigned

This ticket was mentioned in Slack in #feature-shinyupdates by swissspidy. View the logs.


4 years ago

#3 @Nikschavan
4 years ago

This bug came into being after the GitHub issue https://github.com/obenland/shiny-updates/issues/153

Since the update-core.php changes are now part of Shiny Updates V3, This button can be made un-shiny again.

@Nikschavan
4 years ago

Revert github commit from shiny updates plugin - https://github.com/obenland/shiny-updates/pull/165

#4 @ocean90
4 years ago

  • Keywords has-patch added; needs-patch removed
  • Priority changed from normal to high

#5 @swissspidy
4 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in [37973]

Note: See TracTickets for help on using tickets.