WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#37133 closed feature request (wontfix)

Allow editors to set default value for "Open link in a new tab" in "Inline Link Editing"

Reported by: Satri Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5.2
Component: Editor Keywords: close
Focuses: ui Cc:

Description

WP 4.5 introduced the useful 'Inline Link Editing' feature. This feature request is for editors to be able to set a default value for "Open link in a new tab", either enable or disabled it by default. At the moment, it is always disabled.

For use cases where the editor needs all/most new links to open in a new tab, the Inline Link Editor becomes not only useless but actually introduces the additional step of clicking on 'Link options' in order to check the 'Open link in a new tab'.

The solution would be to provide a mean for editors to set a default value to the 'Open link in a new tab' checkbox. Thank you for considering this feature request -- Alex

Change History (6)

#1 @Presskopp
4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #36226.

#2 @Satri
4 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Dear @Presskopp , in all respect, this feature request is different from ticket #36226 which was about providing the toggle in the initial popup. My feature request is rather for a way to set the default for the 'Open link in a new tab' value. Very different.

I'm reopening this ticket on the basis that it is not a duplicate. That said, if Wordpress developers think this should not be implemented, I will of course respect the decision :-) Sincere regards -- Alex

#3 @azaozz
4 years ago

  • Keywords close added

Related: #36809 (Remove target="_blank" checkbox in Advanced Link Modal), and somewhat related #23432 (Review usage of target="_blank" in the admin).

Generally using target="_blank" is discouraged as it makes the site harder to use and reduces accessibility. I won't be surprised if the leading search engines reduce their rankings for sites that use target="_blank" excessively.

In these terms adding the target attribute by default is not feasible for core. If needed, it can be done by plugin relatively easy.

#4 @Presskopp
4 years ago

Just to make my decision clear:

Most preferred was to have the inline dialog as simple as possible, and leave the old modal as "advanced settings" where plugins can extend it.

It' not exactly a duplicate, but reads as plugin-area.

#5 @Satri
4 years ago

  • Resolution set to wontfix
  • Status changed from reopened to closed

Thanks for the valuable feedback @azaozz and @Presskopp . @Presskopp, my request would leave the dialog exactly as it currently is, there would simply be a location (anywhere else) where one could set its default value. But I understand, maybe this could be handled by a plugin and not in core.

I'm eager to see how #36809 will be resolved. If indeed _blank links end up being discouraged, it then doesn't make sense to be able to toggle its default in core.

I'm reclosing this ticket since I now understand it's unlikely that this feature will be implemented. Thanks -- Alex

#6 @DrewAPicture
4 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.