WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#37153 closed defect (bug) (fixed)

insert/edit link dialog does not close

Reported by: ritterml Owned by: azaozz
Milestone: 4.6 Priority: normal
Severity: normal Version: 4.5
Component: Editor Keywords:
Focuses: javascript Cc:

Description

New Insert/Edit Link dialog is obtrusive and doggy.

When I click gear to insert link then insert the link the dialog stays, even when I click elsewhere in the editor.

Change History (4)

#1 @ocean90
4 years ago

  • Focuses javascript added
  • Version changed from trunk to 4.5

#2 @azaozz
4 years ago

  • Milestone changed from Awaiting Review to 4.6

Seems like a duplicate of #36781. The symptoms are different but the bug is with not resetting the state.

#3 @azaozz
4 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 37906:

TinyMCE, inline link dialog:

  • Reset the internal state when doing unlink, pressing Escape, and clicking elsewhere in the editor.
  • Add the unlink shortcut from the wplink plugin as it triggers the new wp_unlink command.

Fixes #36781, #36732, #37153.

#4 @azaozz
4 years ago

#37065 was marked as a duplicate.

Note: See TracTickets for help on using tickets.