WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#37161 closed defect (bug) (worksforme)

Deleting attachment from media modal doesn't auto-select next in selection

Reported by: hipwebdesign Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5
Component: Media Keywords: needs-patch good-first-bug close
Focuses: ui, javascript Cc:

Description

In 4.4.4, when you selected a group of attachments from the Add Media modal, and then deleted the active selection, the next selection in your group would auto-select, allow the user to delete that attachment next without an additional click.

This was convenient, as it would allow a user to delete multiple attachments in sequence without too much hassle.

As of 4.5, this no longer seems to work. When you delete an attachment, you have to manually activate the next item in your selection in order to load its metadata into the side panel and delete it.

Change History (9)

This ticket was mentioned in Slack in #core-media by desrosj. View the logs.


3 years ago

#2 @desrosj
3 years ago

  • Keywords needs-patch added

#3 @joemcgill
3 years ago

  • Keywords good-first-bug added

Confirmed that this is still an issue as of 4.8.

This ticket was mentioned in Slack in #core-js by adamsilverstein. View the logs.


3 years ago

#5 @psorensen
3 years ago

Having trouble replicating this. Can someone please confirm I'm trying to replicate the right process? http://recordit.co/BOBEAiw0QL

#6 @adamsilverstein
3 years ago

I was also unable to reproduce the issue, @joemcgill or @hipwebdesign - are we missing something when testing?

#7 @hipwebdesign
3 years ago

@psorensen and @adamsilverstein — process looks right. I was also unable to replicate the issue.

#8 @joemcgill
3 years ago

  • Keywords close added

@adamsilverstein @psorensen – my fault, I misunderstood the report when testing.

When you have multiple images selected and delete one, the last selected image becomes active. If you only have one image selected and you delete that image, then the focus returns to the "Insert Media" menu item (view screenshot).

I believe this is expected behavior, so this can be closed as fixed.

#9 @adamsilverstein
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.