WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#37169 closed defect (bug) (worksforme)

Broken editor in posts and pages

Reported by: Dinamicore Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5
Component: Editor Keywords:
Focuses: javascript Cc:
PR Number:

Description

Hello support:

In this image you can see the hyperlink modal window goes to the bottom of the page. And the editor is blank and frozen. To make it work again, you have to close the page/post and then open it.

This behavior is present in many sites, with different plugins. Java script conflict?

Thanks

Change History (5)

#1 in reply to: ↑ description @Dinamicore
4 years ago

Replying to Dinamicore:

This is present since 4.5. Not present in 4.4 and below.

Thanks

Last edited 4 years ago by Dinamicore (previous) (diff)

#2 @Clorith
4 years ago

  • Component changed from General to Editor
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Hi there, and welcome to Trac.

I've seen similar behaviors previously when a plugin has interfered with the JavaScript for the editor, judging by your screenshot you have quite a lot of plugins as well as browser extensions loaded which may all interfere.

As the editor works fine on a clean install I would suggest trying to disable your plugins/testing with Twenty Fifteen or Twenty Sixteen as a theme as well as running in incognito mode to rule out any browser extensions creating issues.

#3 @Dinamicore
4 years ago

  • Resolution worksforme deleted
  • Severity changed from normal to critical
  • Status changed from closed to reopened

Hello Clorith, and thanks for quick response.

This behavior started in version 4.5.

Not present in 4.4 en previous.

From a user perspective, it is a bug. I mean, why all the plugins work fine in 4.4, and not in 4.5?. I know that WP updated some js in 4.5, and it may be ahead on time compared with the plugin developers. But, it is a bug from a user (might be not for a developer´s) perspective.

Your thoughts?

Thanks

#4 @Clorith
4 years ago

  • Resolution set to worksforme
  • Severity changed from critical to normal
  • Status changed from reopened to closed

Yes, it would be considered a bug, from both views, but it's a bug with a plugin or theme, not with WordPress core (to be blunt here, if a plugin or theme isn't up-to-date with the changes made in 4.5 by now, you may want to consider replacing the offending plugin or theme.)

You can find details about this in our big 4.5 forum thread https://wordpress.org/support/topic/read-this-first-wordpress-45-master-list which covers many known issues as well.

The best approach you can take is to try disabling your plugins, enable them one at a time until the issue reoccurs and then contact that plugins developer to inform them of the issue so that they have a chance to correct it, I'd encourage you to make a forum thread if you need help in doing so or with further troubleshooting this issue as it's a much more appropriate platform for this than Trac is.

#5 @Dinamicore
4 years ago

Hello again @Clorith:

I deactivated all of the 32 plugins in the site, and the problem is gone.

Therefore, the bug is not in WordPress itself, rather than in the plugins.

However, what is the reality to the users? They will need to go through all the plugins, one by one, and deactivate the culprit or culprits.

Then, they will have to go to de developer of the plugin to try to find out the problem; or they will have to replace the plugin.

Therefore, from a user´s perspective, they might rather leave WordPress in 4.4 version.

The reality is users prefer to stay in 4.4.

WordPress depends on the plugins to be used as a corporate Website; so, the be ahead of time in the update of js that is not compatible with the plugins, is causing corporations to defer the WP update.

I run dozens of Websites, and I can´t deactivate plugins in corporate Websites as I will lose their features. My only choice is to stay in 4.4.

Thanks.

Note: See TracTickets for help on using tickets.