WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#37195 closed enhancement (duplicate)

Validate usernames only once in a multisite signup

Reported by: arkimedia Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5.3
Component: Users Keywords:
Focuses: multisite Cc:
PR Number:

Description

In wpmu_validate_user_signup function there is a double validation for allowed username.

First, the username is passed in to a sanitize_user function and after that tested with preg_match( '/[^a-z0-9]/', $user_name );

Latter test is more strict than the one used in sanitize user function and doesn't allow for example uppercase characters or dots.

I think that the latter test is unnecessary. If it can't be removed, we should add filter for it.

Change History (3)

#1 @arkimedia
3 years ago

  • Focuses multisite added

#2 @chriscct7
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #17904.

#3 @SergeyBiryukov
3 years ago

  • Component changed from General to Users
Note: See TracTickets for help on using tickets.