WordPress.org

Make WordPress Core

Opened 13 years ago

Closed 12 years ago

#3729 closed defect (bug) (duplicate)

Table Structure: varchar(50) for category/term name is too short

Reported by: ice_ Owned by: charleshooper
Milestone: Priority: normal
Severity: normal Version: 2.1
Component: Administration Keywords: mysql categories has-patch commit
Focuses: Cc:

Description

Please change this to varchar(200), like wp_categories.category_nicename. I need more than 50 chars for my category name, cause i use the polyglot plugin and categories are used like this:
[lang_de]Neue Kategorie[ /lang_de][lang_en]New Category [ /lang_en]

That is the name of my category and because of this, why not change to varchar(200), like category_nicename? I changed it manually, but mb some other users dont know how to do this...

Attachments (2)

wp_schema_big_catname.diff (936 bytes) - added by charleshooper 13 years ago.
Sets wp_categories.cat_name to varchar(200) and bumps db version
schema-php.diff (590 bytes) - added by jhodgdon 13 years ago.
Patch compatible with 2.3 bleeding

Download all attachments as: .zip

Change History (13)

#1 @foolswisdom
13 years ago

  • Milestone changed from 2.1.1 to 2.2

@charleshooper
13 years ago

Sets wp_categories.cat_name to varchar(200) and bumps db version

#2 @charleshooper
13 years ago

  • Keywords has-patch added
  • Owner changed from anonymous to charleshooper
  • Status changed from new to assigned

Patch added.

#3 @foolswisdom
13 years ago

  • Milestone changed from 2.2 to 2.3

#4 follow-up: @jhodgdon
13 years ago

Oh no! I just added the above patch to the wrong bug report... how do I remove it? Sorry!!!!

#5 in reply to: ↑ 4 @foolswisdom
13 years ago

Replying to jhodgdon:

Oh no! I just added the above patch to the wrong bug report... how do I remove it? Sorry!!!!

NP, deleted.

@jhodgdon
13 years ago

Patch compatible with 2.3 bleeding

#6 @jhodgdon
13 years ago

  • Summary changed from MySQL Structur: varchar(50) for cat_name in table wp_categories is too short to Table Structure: varchar(50) for category/term name is too short

I have been hoping for a while that this would get patched... I know we who use multilingual blogs are in the minority, but it would sure be handy.

In any case, I have created a new patch for scheme.php, which makes the term name have field length 200, which is compatible with trunk [5744] (i.e. 2.3 bleeding). I didn't bump the DB version in the patch.

If you are not planning to ever patch this, maybe you could just close the bug as "won't fix", so I could give up hope. Thanks!

#7 @jhodgdon
13 years ago

  • Cc jhodgdon added

#8 @f00f
13 years ago

I'd also like to see it changed.
What is the reason for the restriction to 50 chars anyway?

#9 @mastermind
12 years ago

  • Cc mastermind added

A little update, meanwhile this bug refers to wp_terms.name.

WP 2.5 is soon to come, and this annoying bug is still unresolved, even though it should be rather easy to fix. :/

#10 @Otto42
12 years ago

  • Keywords commit added

Anybody planning on committing this anytime soon?

#11 @ryan
12 years ago

  • Milestone 2.9 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #7465

Note: See TracTickets for help on using tickets.