WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 14 months ago

#37313 closed defect (bug) (maybelater)

Right widget sidebar in Edit Post flickers between two positions on scroll

Reported by: ericlewis Owned by:
Milestone: Priority: low
Severity: minor Version:
Component: Editor Keywords:
Focuses: Cc:

Description

See screenshare

Attachments (2)

37313.mp4 (1.2 MB) - added by ericlewis 4 years ago.
37313.diff (1.3 KB) - added by adamsilverstein 4 years ago.

Download all attachments as: .zip

Change History (5)

@ericlewis
4 years ago

#1 @adamsilverstein
4 years ago

Unfortunately, I was easily able to reproduce this bug in Chrome Beta/mac for a new post (in trunk): https://cl.ly/3s3G1T151d1o

#2 @adamsilverstein
4 years ago

In 37313.diff :

  • Add a debouncedScrollHandler in editor-expand.js
  • Use Underscore _.debounce in favor of setTimeout and afterScroll events

@ericlewis can you test this to see if it resolves the issue for you?

The flicker is caused by a secondary call to adjust in afterScroll. - the right bar gets pinned, then unpinned or the other way around, repeatedly.

My only concern here is that afterScroll was added to handle some edge case, maybe @azaozz
or @iseulde can tell us?

#3 @desrosj
14 months ago

  • Milestone Awaiting Review deleted
  • Priority changed from normal to low
  • Resolution set to maybelater
  • Severity changed from normal to minor
  • Status changed from new to closed

This is still reproducible in Chrome 74.0.3729.169. 37313.diff no longer applies to trunk, though.

This seems relatively minor and does not affect the ability to accomplish and perform editing tasks. Since the Classic Editor is in a high priority/major bug fix and regressions only mode, I am going to close this one out.

That said, if someone feels passionately about fixing this, it wouldn't hurt to fix.

Note: See TracTickets for help on using tickets.